Call forwarding with WFH (working from home)

We are trying to set up our system so that the operator can work from home. This is currently set up the following way: Inbound route goes directly to the operator. The operator extension is set up with a follow-me list, which rings her cell phone, and if there is no answer, it goes to the IVR. That works OK.

What we don’t seem to be able to set up is a outing back from the cell phone to an extension. For example, let’s say the operator works from home and receives a call there. The call is for an employee who is in the office, let’s say on extension 123. We would like to set it up so that the operator can receive the call, and upon identifying that the call is for a specific employee, forward the call to the correct extension. Is that possible, and if so, how do we set that up?

You are talking about a softphone app on the user’s smartphone.

Was going to ask the same. If it’s ringing a softphone with the operator’s extension (or a different one) it could be easily transferred. If it’s ringing an external cellphone number I don’t think so.

No. The follow-me number is simply the operator’s cell phone number. We tried putting a SIP phone into her home, but we can’t get it to connect to the phone computer. A softphone might be an option I had not thought about. What softphones will work with FreePBX on iPhone or Android?

Sangoma Connect (as well as others) is a paid option for mobile clients, but if you can’t register a remote hard phone, you will prob have a similar experience with a soft phone.

There are many softphones, but @lgaetz is correct in saying that a softphone will not register same as a desk phone. You will likely need to look at the user’s router and disable any SIP ALG

Thanks. I’ll try that. Isn’t SIP ALG meant to make it easier to connect? Since I have tried multiple times to get this accomplished and have failed every time, do you know if there is a good description of the steps to take?

My experience is that SIP ALG (especially with remote phones) does more harm than good. I cannot give you any advice on disabling because it is specific to the remote user’s router/firewall. I suggest looking up the router documentation.

Follow the Wiki for getting Sangoma Connect setup then you will be able to do everything you asked about above. Its excellent. We use it all the time and our clients love it.

Sofphone is likely the better experience overall, but you could use the asterisk feature codes for blind and attended transfer. In that way operators could continue to use the flow they are already used to.

1 Like

So, after some other pressing business I finally had the opportunity to work on this with one of the IT admins who could control the firewall. We got a little bit further (Ithink) but the phone still does not work. Here is what I observe:

  1. The phone connects to the network at my house with DHCP and gets an IP address 192.168.x.22.
  2. The Asterisk machine is on a separate network (192.168.y.40). That network has access to the internet through a firewall with a static IP address, let’s call it <static IP>.
    The phone has global SIP settings and Line specific SIP settings (it’s a multi-line phone). As far as I understand it the line setting overwrite the global setting. So the Server addresses in the global setting are all 0.0.0.0, the ports are 0.
    The line settings have various servers:
    Proxy Server
    Backup Proxy Server
    Outbound Proxy Server
    Registrar server
    Backup Registrar Server
    and a Port for each one.

Depending on what I put in for these, I get different results. the System information tells what the SIP account used is. that can vary from [email protected] with a status registered to [email protected]<static IP>:5060 with a status unregistered, to various combinations of [email protected]… and status 408. None of them results in a working phone.
The most promising seems to be [email protected]<static IP> with a status of unregistered. I actually get a dial tone in that case, but after few seconds I get a busy signal and the line drops.

That is as far as I have gotten so far. So, I am wondering which one of the servers above I have to specify, and if there are any ports I have to use for them. I should say that I took the settings for a working office phone as a template, and that ended up with a status of 408, so that was no help. I saw in another post that I should use port 5160 for the registration (Registrar Server?) but that did not change anything. I am actually wondering if Ihave any of those servers (there is only one computer which runs Freepbx, so would that be the same computer for all of the servers above? Or should I simply not specify some?

So, still stumped.

Is the x sub-network in the same intranet as the y subnetwork? (This should be achievable using a VPN in the proper sense of the term, and is probably the easiest option to make things work.)

If not, please confirm that that y sub-network is attached to a NAT router with public address p.p.p.p. and that you have one to one port forwarding the SIP signalling address and the whole Asterisk RTP port range.

Please confirm that the x sub-network is connected to a NAT router with public address q.q.q.q and provide details of how that router will know where to send SIP signalling and RTP.

Does the phone have any provision for specifying q.q.q.q?

Note, you are unlikely to need more than primary registrar and primary proxy, and you almost certainly want p.p.p.p there, with the Asterisk signalling port number.

Hi David,

thanks for the response. I will run this by the IT person (they control the firewall).

No, the x subnet is different from the y subnet. the reason is that I can VPN from y to x (and the other way around) with my computer, and that requires that x is not the same as y. But that VPN is on a machine level, not a network level.
Yes, the y network is attached to a router/firewall with NAT and a public IP of p.p.p.p.
The phone asks for IP addresses of various servers, among them the proxy server and the registrar server. At the moment they are specified as p.p.p.p and 5060 for the ports. This results in the phone being unregistered. If I take out these addresses (and replace them, for example with the internal address of the asterisk server) the status changes to “408”. I take that as a sign that there is some communication between the phone and the server, but something is blocking full registration.
I checked with IT, and theyhave forwarded 5060 UPD to the Astereisk server, and also opened th ports for RTP that are listed for Asterisk in on the Asterisk SIP Settings page. But the phone will not register.
The phone sits on my network behind a Firewall, and I have checked those settings as well. And they seem to be all OK. Still no registration. I thought I should see the registration attempts in the Asterisk logfile, but nothing shows up there. Does that mean anything?

If you can do that, they are part of the same intranet, in which case registrar and proxy should be the y network addresses, and the x network should be listed as a localnet on the Asterisk system.

408 is timeout and is usually not a real response but rather faked by the UAC. You would need to look to see whether the request is actually reaching the Asterisk system. although, even if you failed to list x as a local network I can’t think why, if y and x a mutually routable, I can’t think why you wouldn’t get a successful registration.

Is the VPN implemented by the router? (So that even if the phone only has a default route, it will still see a route to y.)

If the request is getting through, you need to look at it to make sure that all the addresses in it are for the x network.