Call forwarding via dial plan stuck

I was trying out 6941’s with an asterisk that was patched with Long story short, it worked well, but still not enough functionality.

Moving along, we tested call forwarding. It worked. But then the call forwarding disappeared from the phone, so no way to remove the forwarded call.


trip the x-cisco-serviceuri- prefix
exten => _[x]-cisco-serviceuri-.,1,Goto(${EXTEN:19},1)
; Enable forwarding
exten => _cfwdall-.,1,Answer
same => next,Set(SIPPEER(${CHANNEL(peername)},callforward)=${EXTEN:8})
same => next,Hangup(normal_clearing)

; Disable forwarding
exten => cfwdall,1,Answer
same => next,Set(SIPPEER(${CHANNEL(peername)},callforward)=)
same => next,Hangup(normal_clearing)

I tried over at that jira page, but nobody answered; is there any way to remove a forwarded call that was forwarded with that type of dial plan?

Such values are stored in the asteriskdb , you can modify the sqlite3 tables directly or interface with asterisk’s CLI use of :-

database (tab-completion)

Thanks Dicko!!!

asterisk -r
database show

/SIP/CallForward/2725 : 2725

sigh OK, that doesn’t quite match up with what I was seeing, but either way to me it explains why I cannot dial the extension. Am I able to delete this from the cli? something like:

>database del /SIP/CallForward/2725

or how does that work?

I just ended up reinstalled the server and reinstating the backup. All good to go now.