Call forwarding not working - no circuits

Hopefully this is something simple!

I’ve just migrated to FreePBX 16. Something my users need is the ability to call-forward from their office line to their cell phone. I assumed the User Control Panel would let them easily do this, but it doesn’t seem to be working.

When a user sets any or all of the three call forwarding conditions (Unconditional, Unavailable, or Busy), and you call their extension, the call is not being forwarded out of our system.

  • When set to “Unconditional”, the desk phone still rings, and eventually goes to PBX voicemail
  • When set to “Unavailable”, the desk phone rings, and instead of going to voicemail it says “All circuits are busy now. Please try your call again later.” and goes to a fast busy
  • When set to “Busy”, the desk phone still rings, and eventually goes to PBX voicemail
  • If I call my deskphone from my cell, pick up the call, and then use my deskphone to transfer the call out of the system, I instantly get the “All circuits are busy, please try your call again later”
  • I can dial external numbers from my deskphone no problem, so it’s like we can’t dial out

Could it maybe be related to passing along caller ID? Something is prevents calls from being forwarded out.

Any ideas? Thanks in advance.

I think you are on the right track. It possible that the SIP trunk provider is not letting the calls go through because of the caller ID you are trying to pass.

Maybe pull some logs from an example call and see if they give us a clue how to make it work.

Thanks for the reply. Here’s a pastebin. Where it says “314XXXXXXX” I have removed my cell number, and “!FIRSTNAME! !LASTNAME!” where I’ve removed my caller ID name.

pastebin dot com/6T4t0h8m

On this test call, I was calling my desk line from my cell phone. My UCP was set to forward calls if busy (back to my cell phone).

I just did some test calls with another user, with largely the same results, except for her the unconditional did ATTEMPT to forward immediately, and busy did ATTEMPT to forward, but both instead just went to her PBX voicemail. Same thing when I tried to forward manually from her deskphone to my cellphone though - “all circuits are busy”

Thank you for your help.

I figured out. It was Caller ID. Under the Trunk settings, changing it from “Allow Any CID” to “Force Trunk CID” completely resolved the problems.

1 Like

This is one of the solutions. The way you do this now will also overrule any personal CID’s you may have set.

Under Find me/Follow me, there’s a section callled “External CID configuration” that controls the CID used when Finding/Follow-me-ing :slight_smile:

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.