Call forwarding from Google Voice Number to my DIDFORSALE Number but dead air

configuration
Tags: #<Tag:0x00007fb47c397820>

(FAK) #1

hi Team,

we are trying to call forward on a Google Voice number(123456789) to DIDFORSALE number(987654321). On (987654321) number we have configured IVR Greeting.

When we dial Google Voice number(123456789) it forwarded to our DIDFORSALE number (987654321) but we can’t hear any greeting menu.

however when we directly dial DIDFORSALE Number it plays the greetings.


#2

In the Inbound Route, set Pause Before Answer to 2.


(FAK) #3

no it doesn’t work.

please find below the trace:

209.216.15.70 -> 172.31.4.102 SIP/SDP 1341 Request: INVITE sip:987654321@1.1.1.1:9050 | 
172.31.4.102 -> 209.216.15.70 SIP 749 Status: 100 Trying | 
172.31.4.102 -> 209.216.15.70 SIP/SDP 1059 Status: 200 OK | 
209.216.15.70 -> 172.31.4.102 SIP 518 Request: ACK sip:987654321@1.1.1.1:9050 | 
209.216.15.70 -> 172.31.4.102 SIP 518 Request: BYE sip:987654321@1.1.1.1:9050 | 
172.31.4.102 -> 209.216.15.70 SIP 657 Status: 200 OK |

#4

Try also setting Signal Ringing. If no luck, confirm that the correct Inbound Route is being selected.
If still no luck, report what happens when the DID is routed to an extension.


(FAK) #5

signaling didn’t work.

I just hear the ringing and I can see in the traces that call landed on my ip or number but our IVR not plays instead we hear ringing.


#6

Confirm that when you route to an extension instead of the IVR it works correctly.

GV has logic to ignore a machine answering. Possibly they have changed some parameters; try setting Pause Before Answer to 5.

If no luck, post another SIP trace, including timestamps.


(FAK) #7

Yes when I set it for extension it directly dials it without any delay.


(FAK) #8


(FAK) #9

I decode a Stream on the call and from google end it says “in case of a fas pickup we ask you to let us know that you are not a voicemail system so you need to press 1 to take this call”


#10

But it shouldn’t be a FAS pickup. Confirm that you don’t have Detect Faxes, Force Answer or Privacy Manager set.


(FAK) #11

Detect Faxes = disabled
Force Answer = no force answer
Privacy Manager = no


#12

I tested this on my system with Signal Ringing enabled and Pause Before Answer 3.
Log snippet:

[2021-07-07 10:56:18] VERBOSE[30634][C-00000418] pbx.c: Executing [1775850xxxx@from-trunk:11] Ringing("SIP/AnveoATT-0000035b", "") in new stack	
[2021-07-07 10:56:18] VERBOSE[30634][C-00000418] pbx.c: Executing [1775850xxxx@from-trunk:12] Set("SIP/AnveoATT-0000035b", "__RINGINGSENT=TRUE") in new stack	
[2021-07-07 10:56:18] VERBOSE[30634][C-00000418] pbx.c: Executing [1775850xxxx@from-trunk:13] Set("SIP/AnveoATT-0000035b", "__REVERSAL_REJECT=FALSE") in new stack	
[2021-07-07 10:56:18] VERBOSE[30634][C-00000418] pbx.c: Executing [1775850xxxx@from-trunk:14] GotoIf("SIP/AnveoATT-0000035b", "1?post-reverse-charge") in new stack	
[2021-07-07 10:56:18] VERBOSE[30634][C-00000418] pbx_builtins.c: Goto (from-trunk,1775850xxxx,16)	
[2021-07-07 10:56:18] VERBOSE[30634][C-00000418] pbx.c: Executing [1775850xxxx@from-trunk:16] NoOp("SIP/AnveoATT-0000035b", "") in new stack	
[2021-07-07 10:56:18] VERBOSE[30634][C-00000418] pbx.c: Executing [1775850xxxx@from-trunk:17] Wait("SIP/AnveoATT-0000035b", "3") in new stack
[2021-07-07 10:56:21] VERBOSE[30634][C-00000418] pbx.c: Executing [1775850xxxx@from-trunk:18] Set("SIP/AnveoATT-0000035b", "__CALLINGNAMEPRES_SV=allowed_not_screened") in new stack

Compare to what happens on your system.


(FAK) #13

@Stewart1,

Thanks alot… this works for me now.

But is there any option from Google Voice Account that we can setup to overcome this.