Call Forwarding Connection OK but No Audio

Having a problem with routing calls to my mobile after hours or after I leave early. I have looked at other posts and have applied many of the remedies suggested.

I need to divert calls using ring group placing the mobile number with a “#” at the end along with one of the extensions. The dial out in ring gorup look like this:
XXXXXXXXXX# (external number)

Dial plans are correct.

Incoming calls are working fine both incoming and outgoing i can call the mobile fine using pennytel trunk, incoming calls are received fine using OZTELL. When the ring group is in play the call is connected and my mobile ring but there is no audio both ways.

I have also tried forwarding calls to a local number using another trunk with the same results.

Any possible solution to this.

SIP_NAT is configured correctly

is the firewall configured properly?

firewall has been completed switched off and the router was also for a short time completely opened up as well.

I can make call through the trunk OK, and i can receives calls OK but for some reason the calls are not forwarded. It seems as though the routing internally audio is not passing though.

Hi, We have the same problem.
Did you already have a sollution for this problem?

[email protected]

No I have not been able to solve it as yet, i will get back onto the problem soon as i have been busy with other things. My next step is to change the router to a different one, but haven’t had much time.

When I do a forward call to a internal line it works.
I see in the CLI that there a 2 channels.
When I forward a call to a outside line, I see in the CLI 4 channels.
I think that could be the problem.
But the sollution I haven’t found yet.

In the “Ring Group” check the “Confirm Calls” box and it will start working, however, you’ll get a voice prompt and have to dial 1 to pick up the call, the caller will hear dead air during this time and your CDR will have a bunch or new entries per call. Have not yet found a better solution.

1 Like

I tried this and obviously the problem lies with Trixbox not the router as I able to hear the “Press 1” to answer the call but was unable to get a responce by pressing DTMF 1 this means Trixbox audio path to the mobile is working.
So it will be back to the drawing board on this one.

check with your trunk provider as to how dtmf is being provided to you as you are out of sync with how they think you should be (dtmfmode= is the command). if can be inband, rfc2833, auto. When it’s right it will work.

Each trunk according to the providers uses RFC 2833. Each trunk has been configured for rfc2833 as per instructions. One of my providers is a bit weird but my tests do not use their trunks for the diversion. I have 3 seperate trunk providers.

In our case the following scene works.
A person calls the number from provider A to our call center,
when the call is forwarded through antoher (more expensive) provider B, it wil work.
But when the call is forwarded through provider A we don’t hear any audio.

But with the dtmfmode I wil try monday.

I have tried all different configuration on mine. None provide audio through put.

Did you already have a sollution for this problem?

[email protected]

I currently diverting from my VSP site at the moment. I have had surgery and finding it difficult to track the source of the problem mostly finding time.

Hi guys,

I have exactly the same problem here - no audio on call forward to mobile/landline phone. The only solution I have found is to tick the ‘confirm calls’ in the follow me settings for the extension with the call forwarding. Then the audio is connected only when I press 1 on the mobile after the call is connected.

I just want to set call forwarding and I want the call transferred without the user on the mobile phone to have to press 1 to accept the call. Also I noticed that if the call goes through to the mobile phones voicemail Asterisk actually leaves a message about ‘incorrect key entry’ or something and then hangsup. How strange ?

Has anyone worked out how to get the incoming caller to be call forwarded correctly to the mobile/landline without the need for me to press 1 on my mobile ?



Hi folks,

I have the same problem here. I’m forwarding an incoming sip call to an external phone (over sip) and have no audio in both directions. If I use Follow-Me and the ‘Confirm Calls’-hack, it works (but this can not be a solution). Forwarding ISDN calls makes no problems, also forwarding over ISDN is Ok.

It seems to me that there is a problem in FreePBX. Would be great if one of the developer can look at it.


I’m having this issue as well. It only seems to affect some numbers, but a customer of ours (a Doctor’s office) is unable to forward out to their answering service. The CDR shows the call being answered properly, but the caller hears nothing but dead air. I can’t use the “confirm calls” trick since sometimes the answering service picks up with a long message before the caller is placed in queue. If anyone has a solution for this issue I’d love to hear it. Thanks!

I have been ill over the last few weeks and never got around to check one suspect. I believe it may be the ADSL Modem/Router but never got the chance to change it. I think it may be that the modem can’t work 2 audio paths in different IP Address’s. I was going to change my modem until I fell ill and never got around to it. If anyone has tried doing this let everyone know.

I’m experiencing the same exact problem. I need the calls to go through without the Confirm checkbox being checked. Has anyone found a resolution to this?


1 Like

I was experiencing this because the SIP Trunk provider. I switched to a different trunk by a different provider and it worked as planned. Not sure why my original trunk provider doesn’t work though.