Call forward virtual extension

I am trying to setup and test a virtual extension so that when I transfer a call to it, then it will forward to a 10-digit number outside the SIP network. Does FreePBX have an option to enable this from the web interface? I have installed the Call Forwarding module, and even tried configuring it from the VM panel but it did not work.

Set up a custom extension. In the dial command box put the appropriate command to dial the external extension. You should be able to figure out the dial command by looking at your trunk and outbound route settings. The outbound route settings would give the clearest example. Look in the “Trunk Sequence” box. For a ZAP trunk it would look something like this:
“ZAP/g0/nnnnnnnnn” where n is the telephone number you would dial to reach the external number.

Hope this is clear enough.


Thanks Bill. I saw that option and will set it up that way. What threw me off is that it is listed as Other (Custom Device) under Extensions. Is there a reason unconditional forwarding is not working from the user portal? It would make a lot more sense to add it as a Virtual Extension.

Really haven’t tried it in other way except the custom ext. I’ve had this system up almost 5 years and the custom ext was about the only thing available back then. It works so that’s the way I’ve left it.


Set up an extension as normal, then do a “follow me” to the number you want to route to. I have a few set up like that.

Thanks but for some reason I can’t get that to work either. Can you think of anything I may be doing wrong? Is there maybe something I can type from the Asterisk console to enable forwarding for the virtual extension?

Outside numbers in the follow-me list need to be in the same form as if they were being dialed from an internal phone (e.g. with or without 1+area code) and have a pound-sign (#) suffix. This tells the switch to route it out the appropriate trunk.

I have it setup this way and have verified the Outbound route is working. For some reason though whenever I dial that extension it just says that it is not available, and does not forward correctly.

I know this is old, but I found this by searching for a solution for the same problem, and just in case there is anybody there with the same issue, here is what i did:

created a virtual extension
created a misc destination with the number I wanted to call
added an ivr with the extension and the misc dest option

hope it helps