Call Flow Control not playing recordings

Hello all,

I am running FreePBX 12 with all the latest updates. I am running Asterisk 11. The system is hosted and all extensions are in the cloud. The system audio is working well. I seem to have a problem with the Call Flow control, it only beeps and doesnt play the default recordings or any custom ones that I select.

I have uninstalled and reinstalled the module and have no joy. the recordings can play in other modules like IVR etc.
The same thing happens no matter what codec I select and from multiple locations. I have a purchased g729 license.

Please help.

Call trace below
== Using SIP RTP TOS bits 184
== Using SIP RTP CoS mark 5
– Executing [*[email protected]:1] Macro(“SIP/799-00000199”, “user-callerid,”) in new stack
– Executing [[email protected]:1] Set(“SIP/799-00000199”, “TOUCH_MONITOR=1477636811.69117”) in new stack
– Executing [[email protected]:2] Set(“SIP/799-00000199”, “AMPUSER=799”) in new stack
– Executing [[email protected]:3] GotoIf(“SIP/799-00000199”, “0?report”) in new stack
– Executing [[email protected]:4] ExecIf(“SIP/799-00000199”, “1?Set(REALCALLERIDNUM=799)”) in new stack
– Executing [[email protected]:5] Set(“SIP/799-00000199”, “AMPUSER=799”) in new stack
– Executing [[email protected]:6] GotoIf(“SIP/799-00000199”, “0?limit”) in new stack
– Executing [[email protected]:7] Set(“SIP/799-00000199”, “AMPUSERCIDNAME=PPIT Test”) in new stack
– Executing [[email protected]:8] GotoIf(“SIP/799-00000199”, “0?report”) in new stack
– Executing [[email protected]:9] Set(“SIP/799-00000199”, “AMPUSERCID=799”) in new stack
– Executing [[email protected]:10] Set(“SIP/799-00000199”, “__DIAL_OPTIONS=trw”) in new stack
– Executing [[email protected]:11] Set(“SIP/799-00000199”, “CALLERID(all)=“PPIT Test” <799>”) in new stack
– Executing [[email protected]:12] GotoIf(“SIP/799-00000199”, “0?limit”) in new stack
– Executing [[email protected]:13] ExecIf(“SIP/799-00000199”, “0?Set(GROUP(concurrency_limit)=799)”) in new stack
– Executing [[email protected]:14] ExecIf(“SIP/799-00000199”, “0?Set(CHANNEL(language)=)”) in new stack
– Executing [[email protected]:15] GotoIf(“SIP/799-00000199”, “0?continue”) in new stack
– Executing [[email protected]:16] Set(“SIP/799-00000199”, “__TTL=64”) in new stack
– Executing [[email protected]:17] GotoIf(“SIP/799-00000199”, “1?continue”) in new stack
– Goto (macro-user-callerid,s,28)
– Executing [[email protected]:28] Set(“SIP/799-00000199”, “CALLERID(number)=799”) in new stack
– Executing [[email protected]:29] Set(“SIP/799-00000199”, “CALLERID(name)=PPIT Test”) in new stack
– Executing [[email protected]:30] Set(“SIP/799-00000199”, “CDR(cnum)=799”) in new stack
– Executing [[email protected]:31] Set(“SIP/799-00000199”, “CDR(cnam)=PPIT Test”) in new stack
– Executing [[email protected]:32] Set(“SIP/799-00000199”, “CHANNEL(language)=en”) in new stack
– Executing [*[email protected]:2] Answer(“SIP/799-00000199”, “”) in new stack
> 0x7f85180ce020 – Probation passed - setting RTP source address to xxx.xxx.xxx.xxx:8000
– Executing [*[email protected]:3] Wait(“SIP/799-00000199”, “1”) in new stack
> 0x7f85180ce020 – Probation passed - setting RTP source address to xxx.xxx.xxx.xxx:8000
– Executing [*[email protected]:4] Set(“SIP/799-00000199”, “INDEXES=0”) in new stack
– Executing [*[email protected]:5] Set(“SIP/799-00000199”, “DAYREC=custom/RedirectOn”) in new stack
– Executing [*[email protected]:6] Set(“SIP/799-00000199”, “NIGHTREC=custom/RedirectOn”) in new stack
– Executing [*[email protected]:7] Goto(“SIP/799-00000199”, “app-daynight-toggle,s,1”) in new stack
– Goto (app-daynight-toggle,s,1)
– Executing [[email protected]:1] Set(“SIP/799-00000199”, “LOOPCNT=1”) in new stack
– Executing [[email protected]:2] Set(“SIP/799-00000199”, “ITER=1”) in new stack
– Executing [[email protected]:3] Set(“SIP/799-00000199”, “INDEX=0”) in new stack
– Executing [[email protected]:4] Set(“SIP/799-00000199”, “MODE=DAY”) in new stack
– Executing [[email protected]:5] GotoIf(“SIP/799-00000199”, “1?end1”) in new stack
– Goto (app-daynight-toggle,s,7)
– Executing [[email protected]:7] Set(“SIP/799-00000199”, “ITER=2”) in new stack
– Executing [[email protected]:8] GotoIf(“SIP/799-00000199”, “0?begin1”) in new stack
– Executing [[email protected]:9] Set(“SIP/799-00000199”, “LOOPCNT=1”) in new stack
– Executing [[email protected]:10] Set(“SIP/799-00000199”, “ITER=1”) in new stack
– Executing [[email protected]:11] Set(“SIP/799-00000199”, “INDEX=0”) in new stack
– Executing [[email protected]:12] GotoIf(“SIP/799-00000199”, “0?day:night”) in new stack
– Goto (app-daynight-toggle,s,16)
– Executing [[email protected]:16] Set(“SIP/799-00000199”, “DB(DAYNIGHT/C0)=NIGHT”) in new stack
– Executing [[email protected]:17] Set(“SIP/799-00000199”, “DEVICE_STATE(Custom:DAYNIGHT0)=INUSE”) in new stack
– Executing [[email protected]:18] Goto(“SIP/799-00000199”, “end2”) in new stack
– Goto (app-daynight-toggle,s,19)
– Executing [[email protected]:19] Set(“SIP/799-00000199”, “ITER=2”) in new stack
– Executing [[email protected]:20] GotoIf(“SIP/799-00000199”, “0?begin2”) in new stack
– Executing [[email protected]:21] Playback(“SIP/799-00000199”, “beep”) in new stack
– <SIP/799-00000199> Playing ‘beep.alaw’ (language ‘en’)
– Executing [[email protected]:22] Hangup(“SIP/799-00000199”, “”) in new stack
== Spawn extension (app-daynight-toggle, s, 22) exited non-zero on ‘SIP/799-00000199’

Hello all sorry…

Noob mistake… I had Feature Codes Beep Only set to true!

Sorry.

The mere presence of all of your brilliance solved this!