FreePBX | Register | Issues | Wiki | Portal | Support

Call Event Logging not working


(bgilbert) #1

I was working with trying to set up a ring group yesterday and when I went to check what was failing using the Asterisk Log Files screen I noticed that during the process CEL stopped running. I’ve tried rebooting, fwconsole restart, I’ve verified Asterisk Log Files and Call Event Logging are enabled in modules.

I don’t understand how or why making changes in ring groups would cause call event logging to stop working unless something strange happened when applying the changes.


(bgilbert) #2

I did go through a few steps, checking the mysql CEL database and it shows no errors and I’ve also verified both the CEL and CDR modules are enabled and running normally.

I’m stuck and Google hasn’t been any help, it’s found a few forum posts and I’ve tried the steps provided in those but none seem to solve the issue. Others are unrelated and seem to based on logging not working after restoring a backup to a new system.

Thanks!


(bgilbert) #3

Some additional notes, this is FreePBX 13.0.195.4 running Asterisk 11.25.3

It seems like looking at the logging it appears to be connecting properly to the mysqld

[2018-06-14 14:58:47] NOTICE[21410] res_odbc.c: Connecting asteriskcdrdb
[2018-06-14 14:58:47] NOTICE[21410] res_odbc.c: res_odbc: Connected to asteriskcdrdb [MySQL-asteriskcdrdb]
[2018-06-14 14:58:47] NOTICE[21410] res_odbc.c: Registered ODBC class ‘asteriskcdrdb’ dsn->[MySQL-asteriskcdrdb]


(bgilbert) #4

Well I’m not sure what happened but now CEL/CDR is working again, very bizarre…


(system) #5

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.