Call cannot be completed as dailed

i have configured a freepbx version 13. i am able to make intern calls and inbound calls through an analog trunk. But when I am testing outbound calls, i am getting “your call cannot be completed as dialed”. I am attaching a screenshot of my dail plan an outbound route

Is it because of the dial plan?

Because of the dial pattern, most likely.

https://wiki.freepbx.org/display/FPG/Outbound+Routes+Configuration+Examples

https://wiki.freepbx.org/display/F2/Outbound+Routes+Module+User+Guide

Provide a call trace via pastebin, maybe there is a clue there:
https://wiki.freepbx.org/display/SUP/Providing+Great+Debug#ProvidingGreatDebug-AsteriskLogs-PartII

okay let me check the links you guys have sent.

The Outbound Route you posted is assuming that users will dial 9 before an outside number. This is not recommended for modern systems, but if you are replacing a legacy system that required dialing 9, you might want to keep it the same.

The device you are calling from is probably not set up for an initial 9 and may send the call to Asterisk after 10 digits have been received, which would cause your call to fail.

hey @Stewart1, i have used 9 because we have a grandstream pbx which we want to replace with the freepbx. And with the grandstream pbx, we used 9. that is why I kept the dial pattern like this. Now I am testing the freepbx analog line by using a panasonic pbx (analog). Is that maybe also the issue? And can you explain me how i can configure a dial pattern whici makes it possible to dial any digits and it would not matter how many of them is received by the freepbx

Numbers could be modified by the device, the Outbound Route, the Trunk, or whatever the trunk is connected to.

If you remove the 9 prefix from the Outbound Route (leave it blank) and keep X. for the match pattern, the Outbound Route will not modify the number.

If you still have trouble, make a test call and go to Reports->Asterisk Logfiles. Look for a line containing e.g.
Executing [[email protected]:1]
This shows that 1234 is what was received from the calling device. If it’s wrong, you have to fix it in the device’s settings.

Towards the end of the log, you’ll see a line containing “Called” with e.g. Analog1/1234 .
The number after the / is what got sent out on the trunk. If it’s wrong, there is a problem with your Outbound Route or Trunk settings.

Okay @Stewart1 i am going to check that what you have said.

@Stewart1 now i am getting line is busy. But I have not changed anything. i am sending you the screenshot of what i get in the Asterisk logfiles.

@lgaetz here is the link of the call trace:
https://pastebin.freepbx.org/view/7281fab7
can you help me analyzing this?

Hi,
One thi i have not told is that i am using a grandstream phone. On this phone is the following dial plan configured: {[*x]+}. I hope this is not conflicting with the freepbx

Is it the right FXO port of the FreePBX that is connected to Grandstream ??

Unable to create channel of type ‘DAHDI’ (cause 17 - User busy)

hi @mcgrathr
I am using an Fxo card and yes it is the right port. I am using port 8 and in the configuration of the dahdi i have indicated channel 8. And i am able to make inbound call. So there is osmething wrong with the outbound rule, I only do not know what exactly.

Ok, verify if port 8 is corresponding to FreePbx outbound route.

Okay I am going to connect the analog line to another port and check if the outbound route works.

hey @mcgrathr i have tried with connecting the analog line to port 1 instead of port 8. the reult is the same. outbound route is not working. Here are screenshots of my conconfiguration.

I really do not know what i am doing wrong

hey you were absolute right.
the the port was not port 8, it was port 1. Now i have connected to port 1(acording to me), i got the same issue. After changing channel to 8 for the “port 1” which is actually port 8, it worked. Now the issue has been solved. I am so sorry for my stupidity. Thank you for showing me that…have a nice day

this issue has been solved. The issue was that I had mistaken in thinking that port 1 is port 8.
After changing channel 8 to chanel 1, the issue has been solved. Thank you all for your advices

Great !!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.