FreePBX | Register | Issues | Wiki | Portal | Support

Call Barge Doesn't Always Work


(Todd Schacherl) #1

I have some users trying to use the barge feature but it doesn’t always work. Sometimes their phone will ring and all they get is dead air. Most other times they can hear the call they are barging in on.

Any suggestions as to what to look for or what might be causing this?

iSymphony (v3.5.4.1)
FreePBX 13.0.195.17


(Dave Burgess) #2

Logs of a failed call would be an adequate start.


(Todd Schacherl) #3

Why not ask for world peace? That would be much easier. Finding needles in the haystack of Asterisk has never been fruitful. Any suggestions on how to even find the logs associated with a call? I tried to search the log for the extensions at play and can’t find anything, “No lines returned.”


(Itzik) #4

I’m trying to understand what @cynjut asked wrong here. I don’t think anyone in the community here is getting paid to post and assist users here (besides Sangoma employees - I’m not even sure if that is outlined in their agreement…)

Dave, like many others, is contributing here and have spent countless hours helping the community.

All he asked is for logs to assist YOU, not the other way around.

You come here to ask for help - when you actually have an option to contact iSymphony (or maybe Sangoma) support since this is a paid module, and complain why Dave asked you for logs.

Yes, we can play the guessing game, but logs should tell you whats up…

Curious. Did you even try Googling?


(Lorne Gaetz) #5

https://wiki.freepbx.org/display/SUP/Providing+Great+Debug#ProvidingGreatDebug-AsteriskLogs


(Todd Schacherl) #6

Because simply asking for the logs seems like a dodge, especially when the log files are super hard to find stuff in. I have yet to find anything useful from a log file. We have dozens of calls going on at any given moment so trying to watch stuff fly by hasn’t been useful. Of course if you have any suggestions, that would be great. The “Providing Great Debug…” still didn’t provide anything useful. For example, If I try to search on the extension to get a system ID, I get nothing. So then what?


(Itzik) #7

You are obviously not following the link, or didn’t read it patiently. plenty of people provide here daily perfect call traces by following that link.

I hope you understand, that we can either guess, or read the logs and see if we can spot something wrong.

I understand that you are frustrated trying to get this issue resolved, but in order for us to help you you gotta help us first to be able to help you…


#8

I would recommend recreating the event, then finding the call record, then reading the section talking about already completed calls on the provided link.

If you are not interested in putting in the time, how can you expect anyone else to? Sangoma offers paid support is an option if you do not have the time, knowledge or interest.


(Todd Schacherl) #9

I tried to do a barge from my extension 202 to extension 1281. I get dead air. I then go to CDR Reports and do a search, several actually where I look first under CallerID Number Exactly matches 202. Nothing shows up. Then I search Outbound CallerID Number exactly matches 202 and no results. Then I search Outbound CallerID Number using my DID number and nothing. I do a search on DID to exactly match my DID number and I get no results. If I try “grep 202 full” I get an endless number of lines which I’m sure is due to “202” matching all kinds of stuff. If I search Destination exactly matches 1281, the extension I tried to barge, I get a list of calls but none of them show my extension or DID.

As best as I can determine, I’m trying to follow the

“Asterisk Logs - Part II Suppose you want a call trace from a specific call that has already happened, so it’s too late to see it in the console live. First locate the call in the CDR, and get the uniquieid from the system column for the call in question:”

and I’m not able to get past the first step. When I look at the docs for the CDR User guide (https://wiki.freepbx.org/display/FPG/CDR+User+Guide) it’s very terse and doesn’t give much explanation on searching for calls.

What am I doing wrong? What am I missing?


(Lorne Gaetz) #10

So if the event you are trying to capture doesn’t appear in the CDR, you can’t use that method. If you open the Asterisk console with asterisk -rvvv and wait for a relative period of no activity, you can then dial the barge code and watch what happens live.


(Todd Schacherl) #11

Therein lies the challenge. There really is no inactive period. I guess I’ll have to set up a lab server to try it and see if I can replicate it there.


#12

You could also “tail -f | grep” the asterisk log located on /var/log/asterisk/full and try the barge, using any two extensions that don’t get a lot of calls and maybe you can catch what’s happening.