Cache path is not writable


(Sergio R) #1

Hi!
I’ve just finished setting up a new FreePBX (15.0.16.72) instance on Ubuntu Server 20.04.
When I access the FreePBX web admin, I get a critical error in the dashboard that reads:
Cache path is not writable! The cache path of /var/spool/asterisk/cache is not writable, caching is not enabled as a result the system might be slower. Please fix this by running ‘fwconsole chown’ from the CLI.
I tried running ‘fwconsole chown’ (again) and restarted with ‘fwconsole restart’ but it didn’t solve the problem. I also restarted the server, but again, it didn’t work. I gave asterisk user permissons manually for that directory, but still, no luck.
Everything seems to work fine, and I installed many modules with success. But, I’m concerned that this will be an issue in the future.

I’ve searched online, but couldn’t find an answer. Other people solved it with ‘fwconsole chown’. Do you know what else I might try?

Thanks to everyone!


(Jared Busch) #2

Looks like it should be owned by asterisk and have 775
image

The better question is why are you doing a non-standard deployment?
Your profile says you are brand new. Going outside the distro is not the best way to start.


(Sergio R) #3

Hi! I’ve manually set permissons to 775 and it seems to work.
I know that going outside the distro is not the best, but this server was running already, and we’re setting this up for a small company. This seemed to be the cheapest way we could do this.
Thanks for your help!


(system) closed #4

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.