Busydetect in chan_dahdi.conf gets overwritten


I cant seem to figure out how to enable busydetect=yes in FreePBX. When I edit the file manually, it works until i make any changes in the GUI–which restores the default chan_dahdi.conf config. Is there a way to specify busydetect=yes in the GUI so it commits the change perminently?



Are you using the dahdi module?

You can set it at the extension level, yes, but there is no option to set the system-wide default. It’d be nice to have such an option in advanced options, perhaps in the ‘Device Settings’ section. And then at the extension level, you’d change the option from yes/no to yes/no/default.

You never answered if you are using the dahdi config module. if so that version is really old and not written by FreePBX. It was submitted by Digium and abandoned. We are re-writing it and should have a beta out next week of it.

I don’t see dahdi anything listed in the module admin page. It would make sense that such an option would be in that module - I look forward to the beta version release.