Busy signal on incoming calls [ I need help]

New here, I’ve read the manual back to back, and read tens of blog posts and I still can’t figure this out.
I’ve setup my sip trunk and outgoing calls are fine. Incoming calls do not get to my server (I can tell by tcpdump output). I need help.

Here’s my config for incoming;

username=My Username
secret=My Passwd

and outgoing

username=My Username
secret=My Passwd

Allow anonymous calls are set to “yes” for now.

Under the embedded Freepbx interface, I set nat seetings to Auto Configure and it seems to have mapped my network right.

Ports 5002 - 5082 and 10000 - 20000 (tcp /udp ) are forwarded.

I can register SIP clients using the public IP and make phone calls between them.

I can make outgoing calls using my sip trunk from the sip clients.

Both my sip_nat.conf and sip_general_custom.conf are blank.

I am stumped, I need help

So I did give my Service provider hell, and they fixed it.
I’ve just got a test call from them and now it’s all working.
Thank you so much magpye, that’s one for you!

A very easy way to see if it’s your provider or not, is to set up a sip client, such as X-Lite with the details provided by the VSP, and then call it from a cellphone or other external line.
Disconnect the PBX from the network before you do this test.

If it rings, then you know the problem is a misconfiguration somewhere in your gear.
If it doesn’t, then it’s a fair chance some is amiss with either the settings in the client or with your VSP.

magpye. Just tested this on Jitsi sip communicator. I can make outgoing calls OK, incoming just are not working. I shut down my asterisk server before trying it out.
So it’s definitely the provider. Thanks again for the help.

Just before you give your VSP a rocket, you might want to have a look at this thread:

It seemed to have some similarities to your situation, FWIW.

Thank you for the reply.

I’ve set up the inbound route as follows;

Descripton : trunk-in
DID # : My DID number
CID # : Any
Set Destination : An extension

I see nothing on the Asterisk Console. Neither do I see anything when I use a packet monitor to inspect incoming packets on eth0. It means the calls are not getting to my server.

What are the common reasons a call would not make it to the server?

The most common reasons are that either the trunk settings are not configured correctly, or the router is blocking the incoming packets.

Just to clarify, you do not have any other lines/trunks/PSTN lines attached to this PBX ? It’s just got the single trunk, that you’re having problems with ?

I’d have a look at the trunk and see if it’s bouncing. Hop into the console and type ‘sip show peers’. It’ll list the trunk(s), and then you can see if it’s registered.
What may be happening is that the trunk is going idle and losing registration, thus causing inbound calls to fail.
If an outbound call is made, it causes the trunk to establish connection to the registration server, and the call completes, albeit slightly longer than usual.

I’ve seen this happen before, and I seem to vaguely recall it was an issue with the router, but I had to scour the logs to pinpoint it, something to do with DNS failure, I recall.
Once I threw in different router, calls worked fine both ways.

Thanks again. Here’s why it must be the SIP provider.
If I register 2 sip clients on my WAN IP, they can call each other, that eliminates the router blocking packets (Since I’ve forwarded all necessary ports). Since my sip provider (freepbx.com store) have not bothered to reply to my support email, am going to go on a limb and try a different sip provider to see if it works. Will post updates here.

Have you set up an inbound route for this trunk ?
If not, you’d be well advised to do so :wink:

If you have, then you might want to see if the call is hitting your PBX. Hop into the asterisk console (asterisk -vr) and place a call from your cellphone to the PBX. If nothing comes up on the screen, then it’s either a trunk problem, or a issue with the provider.
Chances are, out of those two, it’ll be the trunk that’s misconfigured.

If you do see the call details scrolling up the screen, then it’s something to do with either your inbound route , or the extension it’s supposed to go to.
A quick test to find out, is to set the destination of the inbound route to a voicemail box, apply changes, and call again.

If it goes to voicemail, the problem is with your extension.
If it still comes up busy, the inbound route is most likely at fault.

The above is not a comprehensive test, but it’s enough to roughly identify where the problem may lie.

Here are the gateways I was instructed to use and also came in through the auto-config:

SRV: trunk.phonebooth.net
GW1: trunk1.phonebooth.net
GW2: trunk2.phonebooth.net

These are working for outbound but provide no inbound and I’m getting the following messages ever since subscribing:

[May 24 12:00:59] NOTICE[2860] chan_sip.c: Failed to authenticate on REGISTER to ‘[email protected]’ (Tries 1)
[May 24 12:01:19] NOTICE[2860] chan_sip.c: – Registration for ‘[email protected]’ timed out, trying again (Attempt #63)
[May 24 12:01:19] NOTICE[2860] chan_sip.c: Failed to authenticate on REGISTER to ‘[email protected]’ (Tries 1)
[May 24 12:01:19] NOTICE[2860] chan_sip.c: – Registration for ‘[email protected]’ timed out, trying again (Attempt #63)
[May 24 12:01:19] NOTICE[2860] chan_sip.c: Failed to authenticate on REGISTER to ‘[email protected]’ (Tries 1)

Just spoke with Bandwidth.com’s support desk to ask about their SIPStation support and I was told that their is virtually no support for SIPStation customers outside of sipstation.com and freepbx.org.

I guess it’s time to drop SIPStation.com and go elsewhere for my trunks. I do think their advertising is a bit misleading. Seemed to good to be true.

Since you can make outbound calls. It seems you can authenticate just fine.
Are you behind a NATed network? If so, check your firewall.

Go to (Unembedded freePBX > SIPSTATION > Run Firewall Test) and see if everything checks out. If not, you need to open up ports UDP -> 506O and
UDP -> 10000 to 20000

I did all of the above and still no glory. I also put my box directly on the internet without a firewall and nat’ing and still now glory. Any other suggestions?

Try putting the configuration on a SIP client and see if you can receive calls. If you can’t, it’s probably your SIP provider messing you up. Best of luck!