FreePBX | Register | Issues | Wiki | Portal | Support

Bulk handler for contact manager doesn't work


(Fetus) #1

Hi,

I’m tryin to import a few contacts via bulk handler. Everything seems to work properly, and datan validation shows all lines in green. After pressing “Finished” button, there is no contact imported.

I have tried editting the original exported file just editting the plain text, but it doesn’t work. I tried it in FreePBX 13 and also in 14.

Any idea? is it a bug?

Regards


(Fetus) #2

Where are the contacts saved? Are them on a database or files?

Regards


(Dave Burgess) #3

@jfinstrom is the expert on the Bulk Handler. Perhaps you could be a little more descriptive on what you are doing and where you are expecting the result to be?


(Fetus) #4

Well, is quite simple to understand what happens: It simply doesn’t import anything, although the registries appears to be correct for import.

This is what I do step by step:

1.- Create a group and two contacts, from FreePBX pannel:

2.- Export CSV file add new contacts on it:

3.- Edit CSV file with notepad++ (either tried with libre office):

4.- Add new contacts, delete the exported ones and save the file:

5.- Select “Import” oprtion and select modified file_

6.- The new registries are loaded

7.- …adn correctly validated after “import” is pressed:

8.- After press “Finished” button no error is shown and import screen appears again:

9.- But nothing happens beacause the same old contacts are show without the new ones:

10.- Doesn’t seem to work and it happens to me in FreePBX13 and 14 (the only ones I have tried)

:cry:

Regards


(Dave Burgess) #5

It looks like a bug to me, so I’d suggest transitioning this to an Issues ticket. Good work on the troubleshooting - that should help @jfinstrom and the team get the issue fixed.


(Fetus) #6

Thank you! The issue ticket is allready opened.