Bulk Handler DID not working

I don’t know if this needs to be an issue or not, or it could be my incompetence as this is my first go at FreePBX. The wiki on bulk handler and the GUI indicates the recommended/required fields for DID import, but that doesn’t match what is exported from the few I did manually.

For example here are 2 paths that I exported one to an extension, one to a fax recipient. Pardon the wrapping

cidnum,extension,destination,privacyman,alertinfo,ringing,mohclass,description,grppre,delay_answer,pricid,pmmaxretries,pmminlength,reversal ,7265102,"ext-fax,2,1",0,,,default,7265273,,0,,,, ,7265105,"from-did-direct,5415,1",0,,,default,7265415,,0,,,,

Using that as a template I created the one I want to import.

cidnum,extension,destination,description,grppre,delay_answer,pricid,pmmaxretries,pmminlength,reversal ,7265104,"from-did-direct,5352,1",7265352,,0,,,, ,7265101,"ext-fax,2,1",7265296,,,,,,

Tried to import that and got the error. Undefined index: privacyman file:/var/www/html/admin/modules/core/core.class.php:1913

So I moded the CSV to match the wiki and GUI to this.

cidnum,extension,destination,description,fax_enable,fax_detection,fax_detectionwait,fax_destination ,7265104,"from-did-direct,5352,1",7265352,,,, ,7265101,"ext-fax,2,1",7265296,,,,

That returns error. Undefined index: delayanswer file:/var/www/html/admin/modules/core/core.class.php:1904

We don’t do fax detection as each person has their own DID fax extension, so I don’t needs those. Also regarding the destination “ext-fax,2,1” I don’t see how that points to a specific person as a fax recipient.


bump, no help here?

I’m not an expert, but just a stab, maybe it will help. my guess is asterisk is very sensitive to order of creation of things. an example I can’t create a time condition, until I have time group for that condition. maybe what you have done is told it to set a destination that doesn’t exist? if it were me, I would create it using the GUI, then export and see if your import was exactly the same. I’m assuming you have many to do since you are using a bulk import? That will hopefully show you what is missing?

Yah I thought that too, but the destinations are there already.

As far as the export, that is the bug. The exported field layout doesn’t at all match what both the wiki and the GUI says it should be. The first code block is what is exported from the couple manual ones that are already working in the system. However if you look here at the wiki the field layout isn’t the same as the export.

Can you export your DID via handler and see if it also doesn’t match the wiki? It would help rule out my install, vs it being a full blown bug.

Looks like someone else beat me to the bug report. Guess I’ll manually do them there is only 100 or so.


well sorry they beat you to it… here’s mine just so you can look at it… I change the extension to be fake data and description.

Thought I’d update this. Even though there is a bug report out on the doc mismatch, I was still getting an error when using the right format. Interestingly enough I did it in Chrome instead of IE and it worked.