Broadcast Module: Silence When Attempting to Set Destination to Audio Playback

I’m experimenting with the trial version of the Broadcast Module to see if I can use it to dispatch an audio announcement to a set of external phone numbers. I have it setup like this:

The call is generated - but there is no audio playback. In fact, I’ve tried other methods of triggering the playback of an audio file - including setting the destinations to:

  • extensions with hold music (this results in just reg ringing)
  • misc destinations pointed to extension tied to misc application pointed to announcement (silence)

When looking at the log file, FreePBX doesn’t even seem to attempt playback of the audio file:

Running Asterisk 16.9.0 b and FreePBX using the AWS Marketplace distribution put out by TheWebMachine

The call trace shows the call going thru AMD and wait for silence before going to a Misc Destination (not an announcement nor a misc app as you’ve noted above) which dials 9876# in the from-internal context which is not a valid dial string so the call fails.

Your log lines are doubled indicating an unnecessary entry in logger_logfiles_custom.conf

Thank you @lgaetz for your help with this. I’ve shifted the config back to the original setup - where the campaign targets an announcement. Same result.


I’m not getting anything written to the broadcast log :-/

My kingdom for your wisdom on this, @lgaetz. Do you recommend I file a bug with the module itself? I have a fairly stock installation. I’m not sure what I would have existing that would cause the commercial module to misbehave. I want to make a decision on whether or not to purchase it on behalf of my client within the next few days.

Your most recent call trace shows the caller hanging up 6 seconds after answering. The dialplan shows that the call was detected as ‘machine’ so was waiting for a full second of silence before proceeding, which did not happen before the call hung up.

The problem is that it wasn’t a machine. :-/

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.