Blind transfer issues

I’ve encountered an issue with a freepbx setup and blind transfers that i think is a configuration problem but I cant find the setting to fix it. Here’s the scenario;

  • Caller A calls User A
  • Caller B is talking to User B at this time
  • User B transfers Caller B using User A BLF key while it is blinking
  • Caller A and B are now conferenced together

What (should) be happening is the blind transfer just goes into call waiting instead of conferencing. Anyone able to point me in the right direction? Thanks.

Edit: Corrected the scenario based on testing.

How are they transferring the call? If they are using the flashing button, then the issue is that you are likely not doing a blind transfer. That would be device programming, and not FreePBX.

Using the BLF key on the phone (s505). Is there a way to make it be a blind transfer regardless if it’s flashing or not?

First make a blind transfer with the manual process and verify the behavior does not happen.

Then you will know if it is FreePBX or the endpoint. We assume it is the endpoint right now, yes, but we do not know.

Ok. When hitting transfer - flashing BLF, the conferencing of the calls occurs. When hitting transfer - manually dialing the extension#, it does a blind transfer as expected.

1 Like

So that gets into the setup of the Sangoma phone you are using.

I do not have one powered up right now to test with.

I suggest opening a hardware ticket for long term results.

For short term results, sign in to the web interface of your phone and go through the settings manually to see if something makes sense to be the cause.

1 Like

There is a P Code, P24953 to control this behavior

You can change it using the EPM Basefile editor

Thanks Lorne. I am guessing if I make this change I will need to reboot the phones to have it take effect? From the description of this code, I’m a little unsure what it will do. Does it just not let you transfer via BLF while it is in a non-idle state?

I think Save, Rebuild and Update on EPM for Sangoma will push the change without a reboot.

This setting fixed the issue. Thanks

1 Like

Can you confirm you changed the value to 1? Going to open a ticket to have this set by default.

Confirmed, changed to 1. Transferring while active still works, just goes to call waiting as i would expect.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.