BLF Lights are an issue

I have attempted to search for something related to this but I am not doing so well so I thought I would throw it out there and see if anyone can help with this.

Installed from Distro. Up to date firmware and modules 10.13.66-17.

We have standardized on the Grandstream GXP2160 for most of our clients and the problem is that every so often the phone needs to be rebooted for the BLF’s to work. The BLF buttons themselves always work as far as for calling the monitored extension, calling a conference room etc. however every so often the lights are not working.

A call is coming in on an extension the phone has a BLF for and the light just stays solid green, doesn’t indicate someone is on the phone or that the phone is ringing. I reboot the phone and everything works as expected for a week or two and then it stops. I reboot the phone and again everything is working.

I would have to assume that it’s something in the phones firmware causing the issue, I have attempted to use different versions of the firmware while troubleshooting this and all the 1.0.7.x firmware seem to act the same.

When I have problems with phones that don’t stay connected I can usually correct these by lowering the time between registrations or maybe I can try lowering the qualify frequency value or something to get the phone to continue uninterrupted communication with the server.

But I am not sure what to try for phones that the BLF’s stop updating their status. Any ideas anyone?? Anyone else experiencing this problem possibly??

Thanks everyone!!

1 Like

I have the same issue. The issue is with the grandstream gxp2160s. Anytime I do updates I have to reboot all the phones or when asterisk is stopped and restarted.

From what I know this is a grandstream issue and not freepbx.

There are a few posts on here about that issue

Thanks for your reply. well I’m not sure if we have the exact same problems but yes something is going on. I was hoping someone would say that there is like a blf timeout command or something that I could send every so often to get it to start working again.

There was something just the other day about hint subscriptions not surviving “something” in the Granstream phones… It’s not something I was particularly interested in, so I just glanced at it. I don’t remember much more than it has something to do with the way that hints are created and subscribed to.

This doesn’t really help solve your issue, but I have not been able to reproduce the problem on any of our GXP2160’s that are running In fact, I have 12 MPKs set to BLF and connected to the local PBX, then 3 MPKs set to BLF, each connecting to 4 different remote PBXes across a metro-e connection. The phones haven’t been rebooted for several weeks and a quick informal check shows all are displaying the correct activity.

I added this in case you weren’t running the FW.

I just updated mine to the newest version I will test here shortly and report back

So i have around 180 gxp2160s with firmware I just did a fwconsole restart and after asterisk starts again the blf keys do not work until iI reboot the phones

Yup I have to confirm the same here.

Well I think I’m going to go back to firmware, is not helping. I’ll report my findings. @jarvisswope have u tried this? If so what were your results.

I haves tried all firmwares. If I do any modules updates I automatically go into the End Point Manager and reboot all the phones

That is correct. Anytime you restart asterisk the hints are lost. Asterisk does not store them so on a restart they are lost and phone needs to resubscribe so the watchers get recreated.

@tonyclewis Is this a Grandstream side effect or does this practice occur no matter what brand of phone that is used??

From what i have read and was told this is a issue with grandstream. I even have issue when i update modules and it makes the blf keys stop working

It should be a problem for any phone, but Asterisk (under normal circumstances) doesn’t get restarted very often, so the subscriptions to the hints should remain on the Asterisk side.

Module updates should not cause this issue. This sounds like a GS issue to me.

@tonyclewis I don’t have this issue when updating modules. I only have this problem when asterisk is restarted … mostly. Every once in a while I will have an issue where I will need to have my customers reboot because none of their BLF’s are working, but the biggest problem actually seems to be with the call flow (Day / Night) that I have setup.

That seems to fail more then anything, sometimes even when the Call Flow status is not being indicated properly by the LED color the BLF’s monitoring extensions are still working properly. I am currently using .97 firmware and it really seems to be working great at this point.

I had stated earlier in this thread that I was going to go back to .25 firmware however that was before I realized that no phones BLF’s will be correct after restarting Asterisk.

Currently Versions I am using:

PBX Firmware:10.13.66-17
Current Asterisk Version: 11.24.1
EndPoint Manager 13.0.98 Stable
Grandstream Firmware

1 Like

I have had the issue with parking pro I believe and framework. Next time I update I will screenshot them and post

I don’t know what to tell you. When asterisk restarts hints are lost and it’s up to your phone to resubscribe as watchers.

@tonyclewis does the Sangoma phone resubscribe to the hints without rebooting the phone after an asteris Research?

I had a major problem with Yealink phones and the BLFs all going wonky. After wasting my money and time with Sangoma (who I had to chase constantly, and they never solved it and refused a refund), it turned out to be the switch, specifically it was a managed POE switch. Swapped it out for an unmanaged switch and boom all the BLFs worked and have worked flawlessly since.

Just offering it as something you might not have thought about, as it certainly caught me.