Blacklisted number

Hi,

My blacklist doesn’t work 100%.
I have just one question. Where is located the blacklisted numbers.
Are they in the extensions_additional.conf or extensions_custom.conf or another file ?

When I put a number in the blacklist it works but I would like to know where these number are saved.

thanks in advance.

Blacklisted numbers are saved in astdb database:
family: blacklist
key: phone number
value: 1

database show blacklist will list all blacklisted numbers.
Example:
/blacklist/121212 : 1

Thanks for your answer.

I have checked that , all values are set to 1, but I can call these numbers even though.

What’s wrong ?

Can you help me please ?

the incoming caller ID is not matching. look at /var/log/asterisk/full when a call comes in from one of these and post what shows up for the CID?

Blacklist is for blacklisting INCOMING phone calls TO your pbx. Not a way to blacklist OUTGOING calls.
You write

Either I read this wrong or you have not understand what the Blacklist module do. Please read here:
http://www.freepbx.org/support/documentation/module-documentation/blacklist
I see that you also have posted a question in that section.

To clarify:
Blacklist is where you add a number that you don’t want calls FROM. Example:
You receive calls from a company that wants you to subscribe to something, they call you twice a day. You get fed up with that. You see that their callerID is 5551234, you enter in the Blacklist 5551234, the next time the company calls you they are receiving a disconnect (SIT) tone. End of story.

Zach,

You seem a bit confused. blacklisting a number blocks a number from coming into the system NOT blocking you from calling them per your reference “but I can call these numbers”. To block numbers that you don’t want people to dial search for outbound blacklist. There are several different ways to do this and they have been discussed in the last few weeks.

Thanks

you are right

I was a little bit confused about this module.

But the problem is still the same
When I put a number in the blacklist the system does not refuse this number

Not a problem and not the first one either.

zach,
The number to blacklist must match EXACTLY. Set verbose level to 5 and log an incoming call to see the callerID. Enter that exact number in Blacklist and it will be blocked.

Hi

“Set verbose level to 5 and log an incoming call to see the callerID”

I am a beginner in asterisk and freepbx.

How do you do that ?

Thanks

What do you mean when you said “Not a problem and not the” ?
What is the solution ?

thanks in advance

I found how to do that but when I get this number it’s the good one I put on the blacklist. When I put the caller Id number it doesn’ t make a difference.

In fact when I receive a call the system does not check if the either or not this number is in the blacklist

This is what I have when I receive a call. The number 55512345 is in the blacklist.

Executing [[email protected]:1] Macro(“XOIP/g0-0x277278”, “exten-vm|novm|4001”) in new stack
– Executing [[email protected]:1] Macro(“XOIP/g0-0x277278”, “user-callerid”) in new stack
– Executing [[email protected]:1] NoOp(“XOIP/g0-0x277278”, “user-callerid: 55512345”) in new stack
– Executing [[email protected]:2] Set(“XOIP/g0-0x277278”, “AMPUSER=55512345”) in new stack
– Executing [[email protected]:3] GotoIf(“XOIP/g0-0x277278”, “0?report”) in new stack
– Executing [[email protected]:4] ExecIf(“XOIP/g0-0x277278”, “1|Set|REALCALLERIDNUM=55512345”) in new stack
– Executing [[email protected]:5] NoOp(“XOIP/g0-0x277278”, “REALCALLERIDNUM is 55512345”) in new stack
– Executing [[email protected]:6] Set(“XOIP/g0-0x277278”, “AMPUSER=”) in new stack
– Executing [[email protected]:7] Set(“XOIP/g0-0x277278”, “AMPUSERCIDNAME=”) in new stack
– Executing [[email protected]:8] GotoIf(“XOIP/g0-0x277278”, “1?report”) in new stack
– Goto (macro-user-callerid,s,13)
– Executing [[email protected]:13] NoOp(“XOIP/g0-0x277278”, “TTL: ARG1: novm”) in new stack
– Executing [[email protected]:14] GotoIf(“XOIP/g0-0x277278”, “0?continue”) in new stack
– Executing [[email protected]:15] Set(“XOIP/g0-0x277278”, “__TTL=64”) in new stack
– Executing [[email protected]:16] GotoIf(“XOIP/g0-0x277278”, “1?continue”) in new stack
– Goto (macro-user-callerid,s,23)
– Executing [[email protected]:23] NoOp(“XOIP/g0-0x277278”, “Using CallerID “” <55512345>”) in new stack
– Executing [[email protected]:2] Set(“XOIP/g0-0x277278”, “FROMCONTEXT=exten-vm”) in new stack
– Executing [[email protected]:3] Set(“XOIP/g0-0x277278”, “VMBOX=novm”) in new stack
– Executing [[email protected]:4] Set(“XOIP/g0-0x277278”, “EXTTOCALL=4001”) in new stack
– Executing [[email protected]:5] Set(“XOIP/g0-0x277278”, “CFUEXT=”) in new stack
– Executing [[email protected]:6] Set(“XOIP/g0-0x277278”, “CFBEXT=”) in new stack
– Executing [[email protected]:7] Set(“XOIP/g0-0x277278”, “RT=”"") in new stack
– Executing [[email protected]:8] Macro(“XOIP/g0-0x277278”, “record-enable|4001|IN”) in new stack
– Executing [[email protected]:1] GotoIf(“XOIP/g0-0x277278”, “0?2:4”) in new stack
– Goto (macro-record-enable,s,4)
– Executing [[email protected]:4] AGI(“XOIP/g0-0x277278”, “recordingcheck|20081203-172226|1228321345.162”) in new stack
– Launched AGI Script /opt/var/lib/asterisk/agi-bin/recordingcheck
recordingcheck|20081203-172226|1228321345.162: Inbound recording not enabled
– AGI Script recordingcheck completed, returning 0
– Executing [[email protected]:5] NoOp(“XOIP/g0-0x277278”, “No recording needed”) in new stack
– Executing [[email protected]:9] Macro(“XOIP/g0-0x277278”, “dial||tr|4001”) in new stack
– Executing [[email protected]:1] GotoIf(“XOIP/g0-0x277278”, “1?dial”) in new stack
– Goto (macro-dial,s,3)
– Executing [[email protected]:3] AGI(“XOIP/g0-0x277278”, “dialparties.agi”) in new stack
– Launched AGI Script /opt/var/lib/asterisk/agi-bin/dialparties.agi
dialparties.agi: Starting New Dialparties.agi
== Parsing ‘/opt/etc/asterisk/manager.conf’: Found
== Parsing ‘/opt/etc/asterisk/manager_additional.conf’: Found
== Parsing ‘/opt/etc/asterisk/manager_custom.conf’: Found
== Manager ‘admin’ logged on from 127.0.0.1
dialparties.agi: Caller ID name is ‘unknown’ number is '55512345’
dialparties.agi: USE_CONFIRMATION: 'FALSE’
dialparties.agi: RINGGROUP_INDEX: ''
dialparties.agi: Methodology of ring is ‘none’
– dialparties.agi: Added extension 4001 to extension map
– dialparties.agi: Extension 4001 cf is disabled
– dialparties.agi: Extension 4001 do not disturb is disabled
> dialparties.agi: extnum 4001 has: cw: 1; hascfb: 0 [] hascfu: 0 []
> dialparties.agi: ExtensionState: 0
– dialparties.agi: dbset CALLTRACE/4001 to 55512345
– dialparties.agi: Filtered ARG3: 4001
== Manager ‘admin’ logged off from 127.0.0.1
– AGI Script dialparties.agi completed, returning 0
– Executing [[email protected]:7] Dial(“XOIP/g0-0x277278”, “SIP/4001||tr”) in new stack
– Called 4001
– SIP/4001-001d6f80 is ringing
– SIP/4001-001d6f80 answered XOIP/g0-0x277278

e.g. the call log. is this everything from the moment the call hit asterisk?

yes this is everything

The system doesn’t check whether or not the number is in the blacklist .

Normally I should see something like this in the first lines as regards the blacklist:

Verbosity is at least 5
– Accepting voice call from ‘55512345’ to ‘4001’ on channel 0/1, span 1
– Executing Set(“Zap/1-1”, “__FROM_DID=74”) in new stack
– Executing Gosub(“Zap/1-1”, “app-blacklist-check|s|1”) in new stack
– Executing LookupBlacklist(“Zap/1-1”, “”) in new stack
– Executing GotoIf(“Zap/1-1”, “0?blacklisted”) in new stack




Am I wrong ?
Do I need to modify the file dialparties.agi or another file to see the lines above when I receive a call ?

1 Like

Can this company call another member of your system ?

1 Like