Best way to update DPMA?

So I was having an issue with voicemail displaying the incorrect received time when viewing the voicemail details (shows 4/30/20 10:58). I saw where Malcolm had suggested to update DPMA to 1.7. So I started wondering if I was perhaps not on the latest version of DPMA. Dropped into my FreePBX via putty and did a quick check:

    > digium_phones show version
    Digium Phone Module for Asterisk Version 11.0_1.6.0

Ok, so I’m on version 1.6 it appears. What’s the best way to update to 1.7?

You will need to download the new version and install it.

Thanks alan. I’ve been reading through the asterisk wiki on DPMA and I’m not sure if I’m looking at apples to apples. Am I reading my DPMA version correctly (saying that it’s version 1.6)? Current version of DPMA is 2.0 on the digium/asterisk site so I hate to assume I can simply move to that version but nothing says to the contrary. There doesn’t seem to be a mechanism to update via FreePBX like the other modules. Downloaded the file, extract to /usr/lib64/asterisk/modules/ and then do a module reload. I’m still not seeing it display a different version when I check. License status shows good. I’ve got to be missing something.

Don’t just mv or cp a newer over an older while Asterisk is running, 'lest you crash Asterisk.

Your best bet when upgrading DPMA is going to be to stop Asterisk, put the module in place, and then start it again. If you prefer, you can always do:

sudo install -m 755 /path/to/asterisk/modules/on/your/distro

and that won’t crash a running Asterisk. But, you’ll still want to restart Asterisk to get the new version of DPMA running.

Thanks malcolm. Yeah, I stopped asterisk before attempting I just didn’t detail that bit. Thanks for the heads up. I always try to get a good snapshot prior to any attempt at anything outside the FreePBX gui as well just in case I muck up something. I’ll give this a go tonight.

As I get ready to now install 2.1 I wanted to confirm your instructions worked just as advertised. Stopped Asterisk and put in the new DPMA module and started it back up.

Thanks for posting this, not too much info on updating DPMA out there.