Best settings for setting up Android extensions?

When I first got my freepbx setup about a year ago, I wanted to be able to have all inbound calls sent to my cellphone. I have a number of DID’s setup, and whenever someone calls them they route to my cellphone via one of my outbound SIP providers. This worked fairly well, although there was some latency introduced and I needed to purchase credits for the outbound connections.

I recently purchased an Android phone that allows for SIP calls. I am wondering if I can eliminate the cost of my current setup while also reducing latency. My question is as follows:

  1. Will setting up my Android phone as an extension of my FreePBX provide less latency than having inbound calls routed out to the PSTN via one of my providers?

  2. If so, what is the best way for me to setup my Android phone as an extension on FreePBX?

  3. When it is setup as an extension, how to I forward all incoming calls to that extension without using an outbound route (ie only using SIP or a direct connection to the Android device)?

1 - Depends on the quality of your xG connection with your carrier. Even 4G networks have considerable jitter. You need to spend the money on a g.729 license for your Android SIP client. It’s the only hope. GSM is the next best choice if you can’t handle the license.

2 - Just set it up as an extension. You will have to open up SIP and RTP from your wireless providers IP network. Sometimes it takes a few weeks to figure out all the netblocks. The key is to keep your firewall rules as tight as you can.

3 - Set up and inbound route to the extension your created in step 2.

Ok thanks for the quick reply. I just setup two Android extensions for internal testing before I attempt to connect from outside the LAN. However I immediately noticed an issue that I am hoping you can help me with. When I dial from one internal extension to another (300 to 201 for example) the audio is clear however both parties hear their own voice echo. I can only imagine this will get worse once the latency of the 'net is introduced, so do you have any idea what is causing this and how to fix it? Once I resolve this problem I will move on to your suggestions for getting the extension setup remotely.

I don’t know what client you are using. I am using Bria and had to adjust the audio settings to get it to sound decent. It had all sorts of options as to how it worked with the phone.

If you mean on the Android side I am using the standard built in Gingerbread SIP client. I even tried switching to Csipsimple on one of the devices but the echo remained. This leads to me to believe that there is a setting I must change on the FreePBX side. Any ideas?

I Have never heard of such a thing. I have an Atrix, and have used cSip Simple reliably for months, over wifi. It’s unusable over 3g or HSPDA.

I haven’t tried GSM or g729 yet.
If you don’t have a real phone to test with, use a softphone like xlite. I think you will find it’s something related to your phone.

Is NAT set to “yes” on your Android extensions?
Try setting NAT to “no” and see if that helps with the echo.

NAT only changes signalling, I don’t see how it can effect audio.

You are using the SIP client on wifi registered to your LAN IP?

BTW, please change thread subject to something meaningful.


Yes, its the default Google application that all? Android phones have. You can find it by navigating to settings>call/phone>internet call settings. However I also installed Csipsimple on the second Android to see if that helped and the same issue occurred.


Yes, I am using two Android phones each running a different SIP client. They are both connected to my LAN via wifi.

Just to toss out another option, I’ve used SIPdroid successfully.