Basic newbie question - communication between 2 SIP softphone - refused


I created 2 SIP extentions, and configured each on 2 separate device for tests.
the 2 Softphones register like a charm.
When I try to call extension of each other, it says that I’m not allowed.
Plan is to use this as an internal solution, so we have no plans to setup an external connection to a “real” phone number…etc…
I assume I’m missing a basic step ? ( maybe create a dial plan anyway ? )
Thanks =

Show us the configuration of the phone. I’ll be you’re using an invalid context.

Hi Cynjut
I’m using X-lite, for troubleshooting, I made very basic config for almost all parameter

account name 6667
protocol( SIP )
Allow this account for

  • Call ( chekced )
  • IM ( checked )

UserID : 6667
domain : IP of my freepbx ( public one )
password : 6667
Display name : 6667
Authorization name : 6667

Domain proxy
register with domain and receviec calls ( NOT checked )
send outbound via
Domain ( selected )
Proxy ( N/A )

DIAL plan

Thanks !!

Some observations:

  1. Each device needs it’s own account. So one will be 6667 and the other would be anything else.
  2. You need to set up the extensions in the system. You don’t need any trunks if you aren’t going outside the local network.
  3. You need to register with the server to receive calls.

1 phone is defined to 6667 ( for everything ) , the other is defined with 1234 ( same , everything )
the unique common attribute is of course the server IP.
I created an extension for both.
I do confirm that I haven’t created any trunk.
I connect each soft phone to server , but as I said, it says that I’m not allowed …

If the softphones are on the same LAN as the PBX:

Register with domain … must be checked.
Domain: Private IP address of PBX.
Send outbound via domain
On Topology tab, Use local IP address.

On the PBX, set up pjsip extensions, leave all settings as default except for extension number and Secret (set Secret to match what you use for Password in X-Lite).

First test by dialing *65 (should announce your extension number) and *43 (echo test). Once those are working, try calling from one extension to the other.

If X-Lite is on a different network from the PBX, post details about routers on each end.

Hi Stewart, Server is on internet , the 2 soft phones connect to the server from 2 different other public IPs.
it is laptops, so they are conected to Internet and of course, it’s working.
Extension number and echo test are working … but not all the time … very weird.
I’m reinstalling from scratch everything and keep posted

I finally found the solution which was mixing in fact 2 problems / behavior …

First, Freepbx has by default an IDS tool ( Fail2ban) which has blocked me because of my test ( specially soft phone trying to reconnect several time with bad config )
On the top of this, the FreePBX is hosted on AWS. If you stop the instance and then start again ( different from restart ) , you will get a new IP address assign …
Thanks to all for the support , all is set and working for now, I will now play with the IVR !

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.