Bash Not Loading

I am having a very strange issue where I am able to login to the CLI through the console or SSH using the root account, but bash never seems to load. After logging in it shows the normal banner and network information but the bash shell never appears. I can type but it doesn’t result in anything happening. If I am logged in through the console it seems to sit here forever, and if I am on SSH it sits there until it eventually times out.

Everything seems to work like normal in the web UI and I am still receiving phone calls without isses. I have tried rebooting the server as well as manually resetting the root password in GRUB in case that caused something to become unstuck.

I have been in the CLI before in the past. There was an Asterisk update recently that was applied about a week ago. I have copied the updated RPMs below. Could this be the cause?

RPM(s) requiring upgrades:
asterisk18.x86_64 18.13.0-1.sng7 (current: 18.12.1.1.sng7)
asterisk18-addons.x86_64 18.13.0-1.sng7 (current: 18.12.1.1.sng7)
asterisk18-addons-bluetooth.x86_64 18.13.0-1.sng7 (current: 18.12.1.1.sng7)
asterisk18-addons-core.x86_64 18.13.0-1.sng7 (current: 18.12.1.1.sng7)
asterisk18-addons-mysql.x86_64 18.13.0-1.sng7 (current: 18.12.1.1.sng7)
asterisk18-addons-ooh323.x86_64 18.13.0-1.sng7 (current: 18.12.1.1.sng7)
asterisk18-core.x86_64 18.13.0-1.sng7 (current: 18.12.1.1.sng7)
asterisk18-curl.x86_64 18.13.0-1.sng7 (current: 18.12.1.1.sng7)
asterisk18-dahdi.x86_64 18.13.0-1.sng7 (current: 18.12.1.1.sng7)
asterisk18-doc.x86_64 18.13.0-1.sng7 (current: 18.12.1.1.sng7)
asterisk18-odbc.x86_64 18.13.0-1.sng7 (current: 18.12.1.1.sng7)
asterisk18-ogg.x86_64 18.13.0-1.sng7 (current: 18.12.1.1.sng7)
asterisk18-resample.x86_64 18.13.0-1.sng7 (current: 18.12.1.1.sng7)
asterisk18-voicemail.x86_64 18.13.0-1.sng7 (current: 18.12.1.1.sng7)

Does anyone have any suggestions for this?

Did you try with a different SSH client? I wonder if something is wrong with the .bashrc

Yes. I had tried using Putty, the Windows built-in SSH client, as well as directly on the console. No luck on any of them unfortunately.

Browse with something like WinSCP and look for your .bashrc file and check if it’s ok.

Looks like WinSCP is also throwing errors if I try connecting using SCP.
image

I’ll try and see if I am able to get at the file system in another way.

Try this " ^\ "

That doesn’t seem to do much either. :frowning: Looking into trying to repair .bashrc but this is definitely beyond my limited Linux knowledge.
image

From the local terminal can you ctrl-ALT-1 (2,3,4, . . ) into other ‘virtual terminals’ ?

Can you kill the current foreground process ctrl-C ?
Can you put the current foreground process into the background with ctrl-Z ?

Same problem. FreePBX 15.0.23.17

Ctrl + C, Z \ doesn’t do anything, Dicko.

from the local terminal can you get to other virtual terminals ?

If not, I would look at rescuetux or one if its peers.

yikes! rescuetux!
why is this broken? why rescuetux?

It Is apparently broken beyond self repair, you need an agent that is not party to the damage done, (whatever that might be)

That sounds like a rabbit hole I don’t want to go down. I think I’ll just save my configs, re-image and restore the system. Thanks, anyway, Dicko.

Probably safer, it was a rabbit hole you somehow created though, don’t do it again :wink: