Backup is killing my FreePBX

Whenever I run a backup job (to ftp) within FreePBX, my system craps out. When it craps out, I can’t receive calls. I get an error message Backup 4… Error: could not save backup. Aborting!

I am running the following.
Asterisk 13.18.3
FreePBX 10.13.66-22

I can replicate this problem by forcing another backup.

More info > I’ve also confirmed that the same problem happens when using the default local backup

I’ve gone as far as uninstalling the backup module and reinstalling it. I still get the same issues.

Do you have enough free disk space?

yes I do

Would you try a system reboot?

Or… It might be a permission issue.
fwconsole chown
fwconsole reload
And try running the backup again.

I will try that right now

Filesystem      Size  Used Avail Use% Mounted on
rootfs          295G  216G   65G  77% /
devtmpfs        1.9G  156K  1.9G   1% /dev
tmpfs           1.9G     0  1.9G   0% /dev/shm
/dev/sda2       295G  216G   65G  77% /
/dev/sda1       283M  116M  152M  44% /boot


I’ll try adding another CPU to this VM.

It’s been going for a while now. I am still able to call the office. My web browser didn’t timeout this time as I am connecting from a different device which doesn’t have limited timeouts set at the firewall level.

My backup is presently at 6.7GB and growing…

This is what the default job is set to. How long should it normally take?

Depends on your file sizes…

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.