Backup from old version FreePBX Fails

I’m trying to migrate to a newer version of FreePBX and get an error with the restore part of the procedure.

I did a full backup of the FreePBX v12.0.76.6 and was able to get the backup file off the old computer.

I then tried to upload the file using the new FreePBX computer (16.0.33) and the dialog seemed to hang at the 99.97% number.

I went to the /var/spool/asterisk/backup/uploads area and found the file there.

I tried the command:
fwconsole backup --restore full-file-name.tgz

I received an error at “Determining backup file type…”
In Tar.php line 593:
“Invalid characters passed for attempted conversion, these have been ignored”

and then the backup fails to complete. Any help would be great!


It’s possible that the backup file that you got off the old machine is somehow corrupted. How did you get the backup file transferred over to the new system?

there is a chance this is a bug in the tar library with newer php

I used Winscp to copy the file over. I should probably do some checks on the original file, the one com the windows machine and then again on the new pbx.

I’ve never had to check files using Winscp in the past…


Yea, WinSCP should be pretty safe. It’s actually possible that it’s the thing @jfinstrom is mentioning.

Wow, that’s hard core. So, if it’s a bug then it should be repeatable and probably reported. I think I’ve seen some updates to the filestore? module recently. I haven’t tried this on older versions of FreePBX to see what happens there.


I am experiencing this same failure as well now. Same exact flow as Jay. Anyone have luck with a work around?

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.