AWS PBX: can't register remote extension

installed freepbx on centos 7 of AWS, I can go to admin webpage via public ip, then add extension, however the extension can’t connect server(public ip), also add security group for both TCP and UDP on port 5060,

anything wrong?

1 Like

AWS implements a NAT in front of the server, so you have to configure FreePBX as such.

I already did config NAT setting in " ASTERISK SIP SETTING", not enough?

Your help would be appreciated.

Depends on how much you filled in.

Also check that the CentOS firewall is disabled. If you are using AWS security groups you don’t need to use the CentOS firewall also.

I disabled centos firewall and use aws security group to open both TCP and UDP on port 5060, the problem still there, nothing happened.

It’s strange, web-gui shows sip using port:5160, so change port to 5160 and connected, but no sounds can be heard between extensions.

Did you open the 10000-20000 ports for RTP?

1 Like

I did, also tried to open port 5004-5082, but nothing happened.

Did you by any chance solve this problem because I have the same thing that I couldn’t solve