Sangoma Completes Acquisition of Digium: Sangoma Press Release. Community FAQ: Sangoma and Digium Join Together FAQ
FreePBX | Register | Issues | Wiki | Portal | Support

Avaya 96x1 extended Features


(Shawn Lockner) #41

sorry been swamped … have you compared your code to theses

https://www.slockner.com/RDWeb/Pages/chan_sip.c
https://www.slockner.com/RDWeb/Pages/sip.h


(Eric) #42

Just have a doubt, is there anyone able to make the conference and join works after provision with PPM?

As after provision with PPM, the SIP flow of conference join seem like changes to send a SIP REFER like below.

And Asterisk seem like do a transfer instead of conference join.

When there is no PPM provision, the conference can be host within the phone. (the phone locally mixed)

Any idea?


(Unchained) #43

Yes, sure.

I also moved back to Asterisk 13.7.2. But it seems that the original code is much different to your chan_sip.c. Thats makes comparsion difficult.

One thing I noticed is this missing code in the description above:

With this I was able to dial out the full number. Before the phone was directly dialing just after the first digit.

Never the less I still get an incoming call, shown with a =, on the second line. It seems that some code/changes is/are still missing.


(Unchained) #44

grafik

I tried also the Soft Sip Phone. But I can see the same phenomenon there, as soon the Avaya Backend is enabled in the phone.

May somebody is able to find the root cause somewhere in my SIP log.

SIP log


(Unchained) #45

It looks like, that the NOTIFY is causing this issue.

I ran the Avaya phone and the software phone in parallel under the same phone number. Then I dropped a call from Softphone.
This NOTIFY message came then for both phones. Both phones then had also the “=” on the display.

This is the only entry with the IP address of the Avaya phone. The softphone has the IP address .20,
.16 is my FreePBX

I start now another try with 14.5.0. I saw that you also use this version.

— (7 headers 0 lines) —
Reliably Transmitting (no NAT) to 192.168.178.19:5060:
NOTIFY sip:303@192.168.178.19;transport=tcp SIP/2.0
Via: SIP/2.0/TCP 192.168.178.16:5060;branch=z9hG4bK09580239
Max-Forwards: 70
From: sip:303@192.168.178.16;tag=as2a9f4571
To: sip:303@192.168.178.16;tag=1018db5b9cdd425b9ce664_F303192.168.178.19
Contact: sip:303@192.168.178.16:5060;transport=TCP
Call-ID: 3_71e60c5107b5b9ce47e_S@192.168.178.19
CSeq: 111 NOTIFY
User-Agent: FPBX-14.0.3.13(13.7.2)
Subscription-State: active
Event: dialog
Content-Type: application/dialog-info+xml
Content-Length: 204

<?xml version="1.0"?> confirmed

(Shawn Lockner) #46

I am sorry I have been traveling and have not had a chance to dig in to this

There is code that handles the Notify issue. I will try to look at soon can you post you 2 modified files?


(Unchained) #47

Hi slockner.

Here are my files. In the meantime I switched back for some reasons to 13.20.0. The filename isn’t correct. Sorry.

https://www.file-upload.net/download-13319777/chan_sip.c.13_22_0.html
https://www.file-upload.net/download-13319778/Chan_sip.c_diff.html
https://www.file-upload.net/download-13319780/chan_sip.c_org.html

Never the less, the problem with the incoming = call, where I also can see the bridge function/button on the phone, still exists.

The rests looks OK so far:
92.168.178.19 - - [18/Sep/2018:15:20:46 +0000] “GET /96xxupgrade.txt HTTP/1.1” 200 4865 “-” “Mozilla/4.0 (compatible; MSIE 6.0)”
192.168.178.19 - - [18/Sep/2018:15:20:46 +0000] “GET /46xxsettings.txt HTTP/1.1” 200 1332 “-” “Mozilla/4.0 (compatible; MSIE 6.0)”
192.168.178.19 - - [18/Sep/2018:15:20:46 +0000] “GET /Mlf_S96x0_German.xml HTTP/1.1” 304 129 “-” “Mozilla/4.0 (compatible; MSIE 6.0)”
192.168.178.19 - - [18/Sep/2018:15:20:47 +0000] “POST /axis/services/PPM HTTP/1.1” 200 938 “-” “Mozilla/4.0 (compatible; MSIE 6.0)”
192.168.178.19 - - [18/Sep/2018:15:20:50 +0000] “POST /axis/services/PPM HTTP/1.1” 200 1012 “-” “Avaya one-X Deskphone 2.6.17.0 (43258)”
192.168.178.19 - - [18/Sep/2018:15:20:50 +0000] “POST /axis/services/PPM HTTP/1.1” 200 6865 “-” “Avaya one-X Deskphone 2.6.17.0 (43258)”
192.168.178.19 - - [18/Sep/2018:15:20:50 +0000] “POST /axis/services/PPM HTTP/1.1” 200 5498 “-” “Avaya one-X Deskphone 2.6.17.0 (43258)”
192.168.178.19 - - [18/Sep/2018:15:20:50 +0000] “POST /axis/services/PPM HTTP/1.1” 200 12899 “-” “Avaya one-X Deskphone 2.6.17.0 (43258)”
192.168.178.19 - - [18/Sep/2018:15:20:51 +0000] “POST /axis/services/PPM HTTP/1.1” 200 149 “-” “Avaya one-X Deskphone 2.6.17.0 (43258)”
192.168.178.19 - - [18/Sep/2018:15:20:51 +0000] “POST /axis/services/PPM HTTP/1.1” 200 743 “-” “Avaya one-X Deskphone 2.6.17.0 (43258)”
192.168.178.19 - - [18/Sep/2018:15:20:51 +0000] “POST /axis/services/PPM HTTP/1.1” 200 1431 “-” “Avaya one-X Deskphone 2.6.17.0 (43258)”

Could the problem be due to any settings in the PMM? Without activated Avaya backend the SIP calls work without problems.
I have also just seen that my default language with enabled backend has not been selected correctly.

I would be very grateful for your help.


(Shawn Lockner) #48

where is your copy of sip.h?


(Unchained) #49

There it is:

https://www.file-upload.net/download-13319842/sip.h.html


(Unchained) #50

Please wait a moment. I think I have it now.

However, the phone currently shows the settings such as address book from the PPM no longer. I’ll check.

The PPM also writes me a proxy server with the name 03 automatically in the phone. The stored setting is TCP 5060.
Somehow I have weird problems. But the SIP telephony is currently running


(Unchained) #51

It looks like, that the parameter SET SIPDOMAIN 192.168.178.16 turns on the “=” calls on my phones. I tried this with my 9650 and the softphone 7.1.0.0. Both phones showing the same behavior when the SIPDOMAIN is set.

But when I skip this parameter I have no PPM features in the phones. The files are pulled from the server but ignored somehow. With enabled parameter the phonebook is on the phone. In manuall way the behavior is the same. SIP works only with a blank SIPDOMAIN field in the phone for me.

I checked the code in the PPM. Normally I’d expect that the SIPDOMAIN will be set by this script.

Here is my HomeServer.soap from the softphone: https://nopaste.xyz/?528f02d8c975e6cc#8ucxfMa7N21lfxpzxds4qnXsLkMpZ1DrNtlBdiBpW9c=

function SendgetHomeServer https://nopaste.xyz/?ae7c83a4a18ca782#gXsUGMDEAEZBZUfI4lcMsC18LnnJ1CKsufmmjxRQB6U=

Looks strange for me. Without the SIPDOMAIN, the softphone puts all the file in the folder e.g. 303 without the domain. That would may explain the missing PPM settings for me.