Autoprovision issue for sangoma handset

Every time my sangoma phones auto-provision or I force a provision they no longer register. The only change required to get the accounts to register is to remove the “:5060” from the end of the destination address information on the individual handsets’ settings. How can I get the 5060 to stop populating automatically? It does not do it on the default Sangoma Endpoint template, but does for all other templates I have created.
NOTE: I have checked the backup destination and destination port and removed the port from there, but if I leave an IP in that field the port autofills into the empty port field.

Welcome to the community.

What device are you experiencing this on?


What model of phone are you provisioning?

Not likely to be your issue here, but in case you’re not already aware, 14 is past end of life now.

I have 3 different models that are all having the same issue - S205, S505, and S705.

Make sure the phones firmware is up to date. You may need to download from here Phone Firmware Release Notes - Phones - Documentation
Do you have portal redirection setup in the Sangoma Portal?

Firmware is up to date, and we have never used the Sangoma portal, is that something we need to be using? We have had these phones for a few years now and never had this issue until we tried to setup a new location last fall.

How are you doing autoprovision? If you setup your phones in the sangoma portal, reset the phones, they should reach out and pull their config and register.

Auto-provision is from the PBX’s IP. We have never used the Sangoma portal. It is provisioning because the password changes and other settings update.

I was able to edit the basefile in the endpoint manager and remove a line for Account1 that had the colon and then “port” listed. Maybe because there was no port filling in it was just including the colon, causing the issue? Still not sure why it started happening in the first place when it hadn’t happened for years (no update we ran coincided with the change). Phones have been working 24+ hours since that change and provisioned correctly yesterday.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.