Automatically set extension CID on outbound call

Hello,

is it possible to set for all extensions automatically the correct extension CID on an outbound call?
So my number is e.g. 01234 - 45678
I have 5 extensions: 11 - 15
I would like the outbound CID to be: 01234 - 45678 - 11 e.g. for extension 11.

Do I have to set the correct CID in each extension, or is there a possibility to automatically set the extension number on an outbound call?

I have the same problem with the inbound calls, I would like an inbound call with the DID 01234 - 45678 - 11 to call to extension 11.

Thank you

In the extensions option set the outbound cid field to the one that you want to sent to the remote end.
Also set the inbound did with the number that you want to guide to this specific extension.

Yes, but you have to set it in either a custom-context or in the extension setup.

I recommend the extension setup. Set the caller ID to whatever you want it to be and mark all of your outbound routes as “intracompany routes” so the Outbound route doesn’t reset it to the route Caller ID.

I don’t think you can get here from there. The incoming DID will be set by your Telco, and if your phone number is “01234-5678” then that’s what you are going to get. The ‘11’ that you are hoping will be there probably won’t be there. If your Telco will send you the extra two digits, then simply set up an incoming route that points the DID ‘01234567811’ to extension ‘11’.

If you want to set up and IVR, you can have the caller dial the extension.

Thank you for the quick answers.

So I need to set up every extension with the CID / DID settings.
My provider send me the extra digits, this should be possible.

I now have set up 5 inbound routes, for all 5 extension, so everything works fine.
I hoped that there is some automatic, that I don’t need to set up one inbound route for every extension. But no problem :slight_smile: Thank you very much !

There are ways to do this programmatically, but you have to write a special “custom context” to name it work “automatically”.

Honestly, with five extensions, the extra trouble of writing a custom context to split the call out to the extensions from the “extra digits” and then another custom-context to modify the caller ID with the extension number is probably a lot more trouble than you would want to mess with.

If you decide to write these, use the “Issues” tab at the top of the screen and send the FreePBX developers your contexts. That way, if someone else wants to do this, they don’t have to write the code.

Ok that’s great. If I need to set up more extensions in the future, I have a way to do that, without write a route for every extension.

If I want to add a new inbound route I get this error:
SQLSTATE[23000]: Integrity constraint violation: 1048 Column ‘mohclass’ cannot be null

Any ideas?

Your Music On Hold class entry is empty. It should be filled in by the page, so I’m going to guess that there’s something messed up somewhere else in your config.

Hello,

How can I fix this fault?
This is, since I’ve updated all modules in freepbx.

I’ve found the issue.
The problem was, that the Music on Hold was disabled. Maybe that’s because I made some updates, and music on hold needs an extra update. So now it works fine! Thank you.

I am using a BLF lamp to indicate whether I am in the day or the night phase ( via time condition ). The problem is, the light doesn’t light up, even if I am in the night phase. If I make a call, it flowes correctly to the night announcment, while I call the BLF lights up, stays in this state for about a minute, and after that it is dark. Although it is the night state.
I am using SNOM Phones, is this a problem or a “feature” of the phones?

It might not be the phone. The name for the day-night condition is really long and you lose the end of it on the Hints page.

Make sure you’ve got it spelled right (with all of the ‘s’ letter included). The first time I built a Day/Night BLF, I left out the middle ‘s’.

Hello,

I tried to set it to “*[email protected]” and also to “*[email protected]” but this doesn’t work at all. I get no light. If I only set the BLF key to “*271” I get the light, but not to the correct time.

If your time condition switches from da to night, on 6.p.m. does the light go on, exactly at 6.p.m. ?

timeconditions-toggles. I submitted a feature request to reduce the length of this particular item a couple of years ago (I wanted “tc-toggle”) so that you could actually read it on the hints page. I even supplied code. That change was not selected to move forward.

Yes.

Hello,

this is also not working. Doesn’t light up at all. Only with “*271”.
Any more ideas :confused: ?

Is it possible that I have a Time issue?

[2016-06-27 20:35:15] VERBOSE[2605] chan_sip.c:   == Extension Changed *271[timeconditions-toggles] new state Idle for Notify User 16
[2016-06-27 20:36:02] VERBOSE[2605] chan_sip.c:   == Extension Changed *271[timeconditions-toggles] new state InUse for Notify User 16
[2016-06-27 20:38:40] VERBOSE[2605] chan_sip.c:   == Extension Changed *271[timeconditions-toggles] new state Idle for Notify User 16
[2016-06-27 20:39:01] VERBOSE[2605] chan_sip.c:   == Extension Changed *271[timeconditions-toggles] new state InUse for Notify User 16

It should be the day state between 20:30 and 20:40, the BLF keys light up, so it is “InUse” as you can see. As soon as I place a call the state changes to idle as it recognices that it is day state. As soon as the call is over, it is back in “InUse” state. So it seems that it takes the wrong time, somewhere?

I’ve set the timezone via cli to Europe/Vienna, and also in the php.ini to Europe/Vienna.
I’ve set the timezone in the Time Condition to Europe/Vienna. The Server time in the time condition shows UTC ( 2h earlier ) and if I set the times in the time group 2h earlier too. e.g.:

20:10 - 20:20 AND 22:10 - 22:20 then it works, and the BLF is updated. If I only set 22:10 - 22:20 than the BLF isn’t updated, but the call flow is correct.

Which time setting is still wrong now?

I could figure out what is wrong now.

I have to put the correct Timezone in de GUI in advanced settings in “php timezone”. Now the Time in the time conditions is displayed correctly and the phone BLF key lights up correctly! Thank you for all your help!