Auto update disabled?

Hi.

We are using FreePBX 15.0.37.4, and it has worked great. As the admin, I used to get notifications every week which modules needed updating, and I would go in approve them, and the system would then go through the process to upgrade and send me a message that the upgrades were done. Perfect.
The last couple of months (at least) I still get a message, but every time I am told that “no modules were marked for upload” (or something to that effect. Then I get a message like this:
endpoint (Cur v. 15.0.27.26) should be upgraded to v. 15.0.65 to fix security issues: SEC-2023-001 restapps (Cur v. 15.0.19.4) should be upgraded to v. 15.0.41 to fix security issues: SEC-2023-001, SEC-2021-013 pms (Cur v. 15.0.2.38) should be upgraded to v. 15.0.3 to fix security
issues: SEC-2022-001

And finally I get a message that no modules were upgraded.

What is my course of action? Do I need to upgrade the items in the second email manually? Will that restart the auto-update?

The update messages continue to tell me that there are no updates available. So I decided to try to manually update the modules. I went to the Admin-> Updates page and the first thing I see is a red banner at the top with this message:

Undefined variable: latestVersionDetails
File:/var/www/html/admin/modules/sysadmin/CommercialLicense.php:247

Could that be the source of the update problems? How would I fix that?

hi @mike_b please refer to the Issue with SysAdmin "UndefinedVariable: LatestVersionDetails" - #8 by kgupta thread.