Auto call recording not working


I’m relativity new to Freepbx/Asterisk. It’s been fantastic - I have been able to get everything I want working, except this…

I can’t get the “automatic” or forced call recording working (Applications > Call Recording). If I’m on a call and press *1, it beeps and the call is recorded. I can then find the recording in /var/spool/asterisk/monitor and all is good. However, if I create a rule to record immediately it doesn’t work. I’ve tried applying rules to announcements, IVRs or extensions and none seem to work. Any ideas as to why it wouldn’t work or where I can start troubleshooting?

I have set “Extension Recording Override” to enabled (not sure if this matters) and “Call recording format” to wav.

Thanks in advance!

To find out what these options do, simply hover over the tooltip next to the field you have a question about, with your mouse.

I would not set recording override.

OK I’m an idiot - it’s sorted.

I was simply entering something in “Applications > Call Recording” thinking it would take affect when a caller called what was listed under the destination. Little did I know this was the wrong way round. You have to direct callers to the Call Recording, it then starts recording and passes the caller to the destination.

Sorry to hassle everyone - and thanks SkykingOH for your input.

Has anybody seen this issue? I have tried everything I can think of to make the settings under “Applications > Call Recording” work.

Thanks for that - I have disabled Extension Recording Override.

It doesn’t fix the problem though. Any idea where to start troubleshooting?