Audio past exacly 25 seconds

Hello every body!
I’m new on PBX!
I have problems to hear the voice when i answer the call, i have to wait exactly 25 seconds to hear the other person, but the other person can hear my voice properly.

I have installed a FreePBX ( Ver 1.1009.210.62) Asterisk (Ver. 10.9.0)
The scenario is the next one:
I have the FreePBX on internet:
Router (Internal ip, conected to a Firewall Juniper with address, in the router i have configured that all the traffic go to the Juniper.
In the juniper i have opened 5060 and 10001-20000 to the FreePBX.
In the extensions NAT=YES
In Settings (Asterisk SIP settings) typed all the configuration, like public ip, NAT, local networks, etc…
Same Audio Codec in the softphones
And i have followed the next link (


In the LAN i have no problems, but i have it when the extensions are registered from internet.
Extension 1001 (Internet address
Extension 1002 (Internet address
FreePBX on Internet x.x.x.x

All the extension are registered to the FreePBX on internet properly.
When i try to call on internet from Extension 1001 to extensión 1002 through the PBX (x.x.x.x) the extension 1001 can hear the voice of the person from extension 1002, but not vice versa we have to wait, exactly, 25 seconds in order to have bidirectional comunication.

Do you know what is the problem?

Please if you need more information please, ask me!

What type of extensions are these - softphones, Aastra, Polycom? You probably need to enable the STUN options on the phones to make things work correctly.

I’m using softphones!
How i have to configure STUN server in FreePBX?

Thnak you!!!

Don’t do any STUN on the FreePBX server, just point your phones to a public STUN server (Google will provide the details).

Thank you very much!
I will try this options and i will tell you!

Thanks again!

Hello Again!
I have the same problem with STUN server configured,
I have to wait 25 seconds to hear the other voice.

I have the same problem when an Internet Extension call to a extension in the same LAN than the FreePBX

I have configured the stun server in the softphones (
Do you recomend otrher stun server?

any suggestion?
Can you help me, please?


Hello again!
Can you hepl me please?
Do you know how i have to do in order to hear the audio in the first second?
I have to tried, nat, configuring extensión without it,
I have opened all the ports in the FreePbx Links (5060 y 10001-20000)
But i still having the same problem, i can’t hear the other side audio after 25 seconds…

Any suggestions?

Thanks Again!

open ports 10000 - 20000

Thanks for your comment!
I have modified the ports and still no working!
Sometimes works and others no, i will put the FreePBX behind a simetric line in order to check if we are having problems with the internet Line.


I changed the FreePBX behind a symetrical line and now the PBX is working properly!

PD: This line is transparent, the router does not nat!


One important point on the Juniper’s. The interfaces must be in route mode. All NAT should be done in the policy.

Typically in the policy of last resort. MIP’s on top, then connected networks and lastly the NAT policy.

If it is of any interest this forum, all the repo’s and backend servers at FreePBX and Schmooze are behind Juniper/Netscreen’s in HA mode.