Attended Transfer notification to receiving party

I am looking to have either some kind of notification played to an extension when receiving an attended transfer. We are working with FreePBX Distro V13 and Asteriks 11 with Ubiquiti UVP phones. Heres the scenario…

Call comes in and is answered by extension 101. Caller needs to be transferred to Extension 102 so we use attended transfer to call 102. 102 has Intercom auto answer enabled so the intercom is auto answered and the user accepts the transfer. User 101 completes the transfer and 102 is immediately connected without any notification. We are also noticing that the caller ID still shows extension 101 rather than the caller id of the inbound call.

What we would like to have happen is…

Intercom auto answer is needed and works well but we would like to have the attended transfer call either be announced with a beep when connected or to have the phone ring as it would when an a regular call comes through. We would also like to have the inbound caller ID show once the call is transferred.

I know we could put a call on hold and call an extension or park a call and page etc or do a blind transfer (which transfers the caller id properly and rings the phone like we want) but attended transfer is preferable with our office scenario.

This would be a phone feature to have added as the phone itself is handeling the transfer

hi @tonyclewis, thanks for the response. I will ask Ubiquiti as well.

For the caller id, you have to enable rpid and also the phone to support this function

Also you say that you are using attendant transfer. Why do you need some sort of noise to inform the user. The person that originates the transfer can tell the final user the he is transferring a call to him.

The Caller ID piece is easily handled through RPID handling in the SIP settings, as @astbox pointed out.

With the rest, I’ve been trying to follow, and I’m confused.

OK, so you have autoanswer turned on - the call goes to the speakerphone and the person at the other end says “Yeah, I’ll take it.” At this point, why do they need to be notified again? This is the only part that has me confused. Let me see if I’m getting this:

  1. Attendant dials “attended transfer” to pass the call back.
  2. The person at the other end has “auto-answer” turned on, which sends the call to the speakerphone.
  3. The attendant does whatever is required to drop off the call.
  4. The person at the other end either continues to holler at the speakerphone or picks up the handset.

If I understand right, you want a step added between 3 and 4 that hangs up the speaker phone and transfers the call to the recipient again but this time the phone DOESN"T autoanswer and just rings?

As I read and reread this, it occurs to me that you might be transferring the call to the Intercom extension, which would then make sense in the “Intercom Autoanswer” part. If that’s the case, you could do something like this:

  1. Put the caller on hold.
  2. Call the recipient on their actual intercom extension.
  3. Get confirmation they are there.
  4. Recover the caller from on-hold.
  5. Blind transfer them back to the actual extension.

Without something like this, you would end up losing the call to the intercom extension, which doesn’t sound like what you want.

Without knowing more about your phones and setup, I think you might be able to do something like my series of commands in a custom context.

  1. Use a new code.
  2. Have this code take, as an argument, the extension you want to call.
  3. Have it put the first caller on hold (connect him to music, for example).
  4. Have it ring the intercom prefix and the extension. This gives you the intercom auto-answer.
  5. Announce the caller.
  6. When you hang up, have it bridge the original customer back to the extension (without the intercom prefix).

The only jam up is that you can’t really recover the call if no one is back there. In spite of that, something like this might do what you are looking for.

Also why to use auto answer, if the phone supports paging you can make the phone autoanswer when you use intercom mode.
Try the paging features of FreePBX.

@astbox I will take a look at the RPID settings and see if that fixes the Caller ID setting in the attended transfer.

@cynjut Sorry for any confusion! Your initial timeline of what i want to have happen is correct. Currently when a call is attended the final user says “yes I’ll take the call” and the attendant finalizes the transfer and the final user is immediately connected without any notification. What i was looking for was a setting to add a confirmation of transfer beep or at least have the caller ID change to represent the transfer. As it stands once the call is transferred there is no change, it still shows the extension that initially transferred the call. (I’m trying to make it more user friendly and visually representative of the status.) Ultimately if there was a way to have the final users phone ring as it does with a blind transfer that would be awesome. Your solution of putting the call on hold, dialing the extension, and then blind transfering the call does work but is a number of extra steps that I was hoping to simplify.

I am unsure what you mean by “transferring the call to the Intercom Extension”. While using the attended transfer the attendant dials the extension number of the intended recipient and the inbound caller hears on hold music just fine. I think the function of the attended transfer is working the way it is intended i was just looking for an additional confirmation or notification for the final user.

The Blind transfer works just fine for the Caller ID portion, its just the Attended that does not. I have Ubiquiti working on this as well to see if they can replicate the issue.

I should also clarify the “auto Answer”… I have the Internal Auto Answer set in the PBX for Intercom and the phones are set to Intercom so they “auto Answer” an internal intercom call.

Paging is also an option, I am still fairly new to FreePBX so i wanted to see if i could accomplish what i was looking for with the transfers without having to change the users operation of the phone system to paging.

In Asterisk , there is special handling of Intercom and Paging (often lumped in together, but actually completely different things).

The Intercom prefix is *80, So, to dial a phone’s intercom, you’d dial *80extension. This gives you the control you are looking for. This way, everything isn’t “auto answered”, only the things that are actually dialed as Intercom extensions.

Sorry for my ignorance but if I pick up a phone in the office and dial 101 to connect to another extension what is the different with dialing *80101? If I dial just 101 it reacts the way I had intended.

*80 (as a dial prefix) uses the special “Intercom” handling. This allows you to have things like “Intercom Pickup” set up so that only actual Intercom calls get handled that way instead of just ringing another extension on the network.

So you are telling me that, no matter what, you want the call announced to everyone in ear-shot anytime anyone in the office picks up the phone and dials? I would hate getting yelled at constantly like that.

If you remove autoanswer from the phone, when you dial 101 the phone doesn’t answer the call, it waits someone to pickup the handset. If you dial *80101 the phone will autoanswer this call.

Also if you use *2, the astersik attended transfer feaure code, you can make a sound to play before the trasnfer

;xfersound = beep ; to indicate an attended transfer is complete

Thank you both for your feedback. I am going to try some different configurations and see what happens. No normally i wouldn’t want everyone to hear all of the announcements to the entire office but in this particular scenario each person has their own office and so the intercom “auto answer” is the preferred method of dialing an extension. However, I will work on this and see what i can present to them as alternatives.

I just found this on the issues page…

This was the “issue” i was describing. @astbox where do i add the “xfersound=beep” in V13? I can’t seem to find the field in the advanced config.

we get complaints about this all the time. neither party knows that the transfer is complete so they both sit there waiting for something to happpen - eventually one of them says hello. it would be really great if the called party had a positive indication that the attended transfer was complete

1 Like

I did a little more testing last night and came up with the conclusion that the problem lie with the phones. The phone has a setting for incoming call action where you can specify Ring, DND, Forward, Auto Answer, or Intercom. When set to Ring the phone will ring every time regardless of the PBX setting, the phone rings on either an inbound call or internal call (such as Attended Transfer) adn regardless of the feature code used. Interestingly though when on the RING setting the Caller ID shows up just as expected during the Attended Transfer.

When set to Intercom (as we have it) when an internal call is placed the phone picks up and announces with a beep, just as expected. But when an Attended Call is transferred the Caller ID shows the extension calling not the Caller ID of the inbound call.

I have sent a message to Ubiquiti and they are aware of the scenario.

1 Like

You should just open the features.conf file and put the line inside. After that reload asterisk.
Bare in mind that this works only if you are using the feature code method. If you are using the transfer button on the phone it will not work because the transfer is being initiated by the phone and not asterisk.

Understood @astbox… We are using the transfer feature on the phone just for ease of use.