"Attempting to activate, please wait..."

Hope this is a simple one. I just went to add a trunk on my new installation, when I got the “Do you want to Activate, Activation is Optional…” screen.

I went through the entire enrollment process, finally clicking “Activate”

A Deployment ID was generated, but Activation never completed. I’m now unable to do anything other than administer modules in the GUI, as it always redirects me back to the activation window; my PBX is now totally unuseable.

All modules are current as of 4/20/15

Asterisk CLI
Asterisk API 12.0.2
FreePBX ARI Framework 12.0.7
FreePBX Framework 12.0.54

I’d upload an image, but as a new user I’m not permitted to.

Any assistance it greatly appreciated.


OK, that’s bad. For the interim, you can remove the <oobe> line from /var/www/html/admin/modules/sysadmin/module.xml - that’ll disable that.

I’d love for you to open a commercial ticket on this, as a bug, and let me log into your machine so I can figure out what’s going on 8-(

(This will NOT be charged, and you do not need to buy support credits, simply refer to this forum thread and it’ll get assigned to me)

Hey, thanks for the follow-up.

Looks like it may have been a remote server availability issue (is that likely?).

Prior to initiating a reinstallation from scratch, I decided to click “Activate” one last time (after having messed with it for ~90 minutes and posting my note). Activation completed this time in less than a second and my PBX is fully functional again.

No changes had been made to the box prior to it working, nor was there any variation to the process I was following.

I’m fine with you looking at it if you think there is any forensic benefit. Let me know and I’ll make it happen.


Availability shouldn’t be an issue. If it can’t reach the server, it just aborts and goes away. Hmm. I’ll rummage through the logs and see if I can spot anything.

Sorry about that! Let’s assume it’s fixed and it was a random glitch :sunglasses:

All good here. Trunk is up and I’m talking to my Patton device. Looks like I’ll be ready to go live this week after all. :wink:

Thanks for everything Rob.


Currently I seem to be experiencing exactly the same problem. I’ll keep trying the Activate button for a bit and see if the problem goes away on it’s own at some point as it did for Steve.

Finally after waiting 16-17 hours I pressed the Activate button again and it worked. As far as I’m aware, nothing changed on my end. So it sounds just like what shayter experienced (only with a much longer time before it started working).

We installed a new system yesterday and experienced the exact same thing,… we are still experiencing the issue and we did open a commercial ticket.

Thanks for help Robert… I will do another install sometime over the weekend and will report back in the forum for you. Thanks again

I would like to add that I have had this problem too. Hopefully someone will start to take it seriously.

I installed FreePBX on a dedicated machine and got to the “Activating deployment…” bit and it did nothing. I re-installed because I thought Internet connectivity issues may have been to blame but I got to the same point (with a new deployment ID) and it stalled again. I finally managed to navigate away and setup my PBX which I assumed meant the deployment ID activated. I setup my PBX which involved several reboots.

The next morning when I go to login it now wants to activate the original deployment ID and won’t let me past the same “Activation” page. I have visited Schmooze (on the advice of this article (google registration issues schmooze and it should come up, I can’t post links)) and I can see the 2 deployments there but can’t see how to delete one or how to confirm that they are activated or any other actual helpful details.

I should note that both times I installed FreePBX, after the install it tried to boot and had some kind of error that it said “May be an Internet connection error” and asked that I run “/etc/pbx_first_boot.sh” after confirming my internet connection. The second install I definitely had reliable Internet and after rebooting it passed the “Internet test” and I couldn’t find the file it mentioned in /etc/ so I assumed it all worked. This may or may not have something to do with the deployment thing. just giving as much details so we can nut this out.

Based on the info here I’ll keep hitting that activate button and hopefully I get back to administrating :smiley:

UPDATE: So I went to Schmooze and followed the prompts to reset Zend ID on the OLD deployment ID and now my machine is using that ID the modules that I bought are disabled. Not very happy. Is there a really basic How To to set and keep the correct deployment ID for my machine? Am I even supposed to have 2 for the same machine and why is it just now deciding to jump back to the old one?

Sorry to keep replying.

Here’s bullet points because we all like bullet points

  • Installed FreePBX first time, got Internet errors on install but after reboot all was fine.
  • Got to Deployment section, filled it all out with Deployment ID 1 and hit activate. Nothing. Absolutely nothing.
  • Reinstall FreePBX, rinse repeat above but with Deployment ID 2
  • Eventually get passed activation (no real “yay, you did it message”, I was just suddenly able to get to the Digium Add Ons menu)
  • Setup my “working” PBX with all my settings, spend all day because I’m hardcore
  • Come to work next day, need to configure something in EndPoint Manager which I bought, greeted with “Please activate your deployment” with pre-filled deployment ID 1
  • Think, why not, hit activate. Nothing happens
  • Google a bit and decide to take the advice and login to Schmooze. Fail to read instructions because I’m young and hot headed. Post here the first time.
  • Re-read instructions and Deactivate Zend ID for deployment ID 1. Attempt to follow instructions to go to System Admin and click De-activate there but still have deployment activation window.
  • Accidentally hit abort which was actually a good idea. Follow Schmooze instructions and deactivate.
  • FreePBX is now not activated and I’m asked if I want to activate it.
  • Go back to Schmooze and de-activate Zend ID for Deployment ID 2.
  • Go back to PBX and say “yes, I would love to activate my machine”
  • enter Deployment ID 2 because that’s the one with the licence for EndPoint Manager.
  • Hit activate and…. There’s a hole in my bucket :stuck_out_tongue:

But this time I’m not re-installing and I’ll keep hitting that activate button and hopefully, fingers crossed, FreePBX forgets all about deployment ID 1 and it never comes up again. Based on the helpful hint, when I clicked deactivate in system admin it thinks I want to move my deployment to a different machine so hopefully it stays in limbo the rest of it’s sorry life.

I’ll let you know when the activate button actually works. According the Schmooze it has worked, deployment ID 2 has a new Zend ID. And the little loading bar at the top starts and stops. It’s just the webpage doesn’t load anything to suggest it has worked. I’m not in charge of the Firewall so I can’t guarantee that isn’t the heart of all my problems but I’ll try and quiz the guy that is later too.

So, uh, is that good or bad? Activation issues are normally handled by the support guys, by logging a support ticket.

Bad. As in I got the same thing again. Still hitting the activate button.

Sorry, I assumed this was a good place to put it since it’s the same place those other people did and they seemed to get a response. Not sure how OPTN went in the end though I guess, maybe he just logged a support ticket.

If I log a support ticket and they fix it I’ll put what they did here so future googling people don’t need to log the same support ticket.


Well, I’ll PROBABLY be the guy who fixes it when you DO log a support ticket, and as you’re around now, let’s see what I can figure out…

I’ll send you a PM now, so I can have a look through the logs.

Edit: For those reading later, the problem was a buggy web browser… If you’re having a problem trying using Chrome or Firefox!