Aterisk or other phonebook to Grandstream contact or phonebook? Part 2

Hello @sorvani,

I did get the script to work and generate the XML file by going to the URL, but when I put the URL into the phone it never pulls the data.
I go to the phone “Phonebook XML Server Path” and provide https://10.1.10.10/pbook/gs.php, which results in a good phonebook file xml format visually seen on the phone, but when put into the phone, it never takes the data. Is there another place or setting I need to get this to work, or is this possible a phone issue?
Thanks!

Does it work with http? Using HTTPS without an fqdn might be a problem for the phone.

Yes, if you put https it does come back, however its not secure so you do get an error in the browser for non-https.
Results are there.

This is how I put it on the phone manually, to then configure in firmware options of EPM, but needed to make sure it worked first.

Try adding your FQDN associated with 10.1.10.10 in the local name service the grandstreams are querying

It made no difference if it was IP or FQDN

Is your FQDN actually secure?

You never did as @lgaetz said and simply used http

it is not secure, tried it with both http & https.