AT&T trunk not registering

Had a hard drive fail and took everything with it (my bad for no backup). I’ve got most everything going again except for our AT&T trunks. They were SIP, but now when adding new trunks the only option is PJSIP. When doing a “sip show aors” command I get:

  Aor:  ATT-SIP-01                                           0
Contact:  ATT-SIP-01/sip:                  c28d8d50b3 Unavail       0.000

not sure where it’s getting just the sip: and not a pjsip. And of course nothing is working when the trunk is unavailable.

Worked with AT&T and they said the see my Asterisk IP hitting their modem show they feel it should be working. Any ideas?

Using FreePBX 16.0.19 and Asterisk 13.38.3.

Most AT&T setups use static configuration; there is no registration. The AT&T on-site SBC is configured with the IP address and port of your PBX and that’s where it sends calls. In your old system (using chan_sip), did you have a Register string? If so, post your chan_sip trunk configuration and we can provide the pjsip equivalent.

Assuming you have the typical setup (without registration), at the Asterisk command prompt type
pjsip set logger on
and make a test incoming call. Paste what appears in the Asterisk log at and post the last 8 hex digits of the link.

If nothing in the log, run sngrep and report what, if anything, appears there on an incoming call attempt. If nothing there, either, confirm that the AT&T SBC is sending calls to the IP address of your PBX.

Note that if your old system had both pjsip and chan_sip, the defaults were pjsip listening on port 5060 and chan_sip on port 5160. In the new system (pjsip only), the default port is 5060, which may not be where AT&T is sending your calls.

It would also be useful to paste a log of an attempted outgoing call.


You were ever so close. I went out to a local Asterisk service company and the rep and I finally solved it. PJSIP uses port 5061 where as ATT was on port 5060. The new Asterisk/FreePBX doesn’t have the chan_sip module so everything I was entering was port 5061. Added chan_sip, configured a trunk the old way, and all is good now. I think the ultimate solution is to have AT&T change to port 5061 and then get rid of chan_sip.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.