Asus Eee PC 900

Running Asterisk for many years on a box in my basement was starting to look like a waste of electricity. I decided to create sub accounts on my account and have each of my six ip phones register directly with allowing me to turn off my Asterisk machine. Well it kinda worked but I was having random issues and overall my setup went from stable to problematic.

After a month or two of this I decided that I should get a PBX going again. Instead of my usual Ubuntu install followed by apt get install asterisk (or something like that) I gave some thought to 3cx then I came across talk of Elastix which I tried and it worked but I had some issues. So while looking for answers to my Elastix problems I realised that Elastix is based on FreePBX.

So I reformatted with:

and everything is working great!

So then I started to feel bad about the box running 24 hours a day and wasting electricy… when I eyed that old Asus Eee PC 900 sitting on a shelf collecting dust.

I connected the external USB DVD drive and tried to install FreePBX – Error wrong architecture, 32 bit CPU I guess…

Download and burn to CD:

During this first attempt I choose the default install with the software raid and ended up with not much free space as the setup was based on the 4GB drive.

For those that don’t know the Eee PC 900 has two SSD drives. When this model came out SSD was new and expensive. To keep the price down they decided to put two SSD drives (chips) in the thing, an expensive 4GB SSD based on faster technology and a cheaper 16GB SSD based on older cheaper tech. The idea being to install the OS on the 4GB and data would go on the 16GB.

I went into the BIOS and disabled the 4GB SSD.

Install again from CD and chose the ‘no raid’ option.

Installation was successful and is on the 16GB SSD. Performance seems fine.

I used Admin->Backup on the ‘power sucking box’ and Admin->Restore on the less demanding Eee PC and all is well.

Three days now and my silent Eee PC PBX is running well and not sucking up too much power (I hope), I only wish that I could have back the $600 I paid for the netbook, which until now I have never had any real use for.

S U M O !!!