FreePBX | Register | Issues | Wiki | Portal | Support

Asternic Stats not updating?!?!?


(Quintis5150) #1

using asternic stats pro 2.0.5

After a restart of freepbx, everything came back up but the STATS. it is telling me how many calls are in queue and how many people are logged into each queue but ‘answered’ and ‘abandoned’ and how many calls the CSR’s took are all at ZERO. It is not updating. They have been logged in since 8am and have answered a lot of calls this morning.


(Avayax) #2

Open a ticket with the developers at http://support.asternic.biz/


(Quintis5150) #3

Thank you avayax! I did this morning. thought I would see if would have any luck on here.


#4

check if the service is running

ps -ef | egrep “tailq|asternic”

if nothing appears

/etc/init.d/asternic start or

service asternic start

depending on your distro


(Quintis5150) #5

Thank you @sanjayws !! I tried and got this:

ps
PID TTY TIME CMD
1 ? 00:00:29 init
2 ? 00:00:00 kthreadd
3 ? 00:11:47 migration/0
4 ? 05:02:42 ksoftirqd/0
5 ? 00:00:00 migration/0
6 ? 00:25:06 watchdog/0
7 ? 00:01:29 migration/1
8 ? 00:00:00 migration/1
9 ? 03:04:09 ksoftirqd/1
10 ? 00:02:11 watchdog/1
11 ? 00:00:48 migration/2
12 ? 00:00:00 migration/2
13 ? 01:03:03 ksoftirqd/2
14 ? 00:01:52 watchdog/2
15 ? 00:26:32 events/0
16 ? 00:07:40 events/1
17 ? 00:07:04 events/2
18 ? 00:00:00 cgroup
19 ? 00:00:00 khelper
20 ? 00:00:00 netns
21 ? 00:00:00 async/mgr
22 ? 00:00:00 pm
23 ? 00:01:08 sync_supers
24 ? 00:01:02 bdi-default
25 ? 00:00:00 kintegrityd/0
26 ? 00:00:00 kintegrityd/1
27 ? 00:00:00 kintegrityd/2
28 ? 02:34:11 kblockd/0
29 ? 00:40:43 kblockd/1
30 ? 00:26:19 kblockd/2
31 ? 00:00:00 kacpid
32 ? 00:00:00 kacpi_notify
33 ? 00:00:00 kacpi_hotplug
34 ? 00:00:00 ata/0
35 ? 00:00:00 ata/1
36 ? 00:00:00 ata/2
37 ? 00:00:00 ata_aux
38 ? 00:00:00 ksuspend_usbd
39 ? 00:00:00 khubd
40 ? 00:00:00 kseriod
41 ? 00:00:00 md/0
42 ? 00:00:00 md/1
43 ? 00:00:00 md/2
44 ? 00:00:00 md_misc/0
45 ? 00:00:00 md_misc/1
46 ? 00:00:00 md_misc/2
47 ? 00:00:03 khungtaskd
48 ? 00:02:06 kswapd0
49 ? 00:00:00 ksmd
50 ? 00:00:00 aio/0
51 ? 00:00:00 aio/1
52 ? 00:00:00 aio/2
53 ? 00:00:00 crypto/0
54 ? 00:00:00 crypto/1
55 ? 00:00:00 crypto/2
60 ? 00:00:00 kthrotld/0
61 ? 00:00:00 kthrotld/1
62 ? 00:00:00 kthrotld/2
63 ? 00:00:00 pciehpd
65 ? 00:00:00 kpsmoused
66 ? 00:00:00 usbhid_resumer
97 ? 00:00:00 kstriped
164 ? 00:00:00 scsi_eh_0
165 ? 00:00:00 scsi_eh_1
171 ? 00:13:39 mpt_poll_0
172 ? 00:00:00 mpt/0
173 ? 00:00:00 scsi_eh_2
290 ? 05:57:36 jbd2/sda2-8
291 ? 00:00:00 ext4-dio-unwrit
292 ? 00:00:00 ext4-dio-unwrit
293 ? 00:00:00 ext4-dio-unwrit
329 ? 07:14:18 flush-8:0
622 ? 00:03:01 vmmemctl
881 ? 00:00:00 jbd2/sda1-8
882 ? 00:00:00 ext4-dio-unwrit
883 ? 00:00:00 ext4-dio-unwrit
884 ? 00:00:00 ext4-dio-unwrit
988 ? 00:02:16 kauditd
1417 ? 01:44:06 vmtoolsd
1536 ? 00:00:00 pppoe-server
1547 ? 00:10:15 auditd
1571 ? 00:00:00 portreserve
1581 ? 00:02:24 rsyslogd
1659 ? 00:20:53 irqbalance
1721 ? 00:00:01 mdadm
1754 ? 00:00:00 cupsd
1786 ? 00:00:00 acpid
1799 ? 00:00:00 hald-runner
1844 ? 00:00:00 hald-addon-inpu
1873 ? 00:02:09 automount
1921 ? 00:00:00 xinetd
1981 ? 00:00:00 mysqld_safe
2138 ? 00:03:08 sendmail
2186 ? 00:00:00 atd
2198 ? 00:00:01 incrond
3236 ? 00:08:19 tailqueuelog
4225 ? 00:00:00 bluetooth
8620 ? 00:00:00 udevd
9880 ? 00:00:00 miniserv.pl
9882 ? 00:00:00 sh
9883 ? 00:00:00 ps
10304 ? 00:00:00 anacron
17870 ? 00:01:52 sshd
20149 ? 00:00:00 httpd
23179 ? 00:00:00 safe_asterisk
23297 ? 00:01:53 fail2ban-server
24245 ? 00:00:00 udevd
24846 ? 00:00:03 udevd
30647 ? 00:00:38 crond
31505 ? 00:02:32 miniserv.pl
service asterniclog start
asterniclog: unrecognized service
ps -ef | egrep "tailq|asternic"
root 3236 1 0 2015 ? 00:08:19 /usr/bin/perl /usr/local/parselog/tailqueuelog -u root -p passw0rd -d qstatspro -l /var/log/asterisk/queue_log
root 10924 10923 0 07:37 ? 00:00:00 sh -c (ps -ef | egrep “tailq|asternic”) 2>&1
root 10925 10924 0 07:37 ? 00:00:00 sh -c (ps -ef | egrep “tailq|asternic”) 2>&1
root 10927 10925 0 07:37 ? 00:00:00 egrep tailq|asternic
service asternic start
asternic: unrecognized service
/etc/init.d/asternic start
sh: /etc/init.d/asternic: No such file or directory


(Quintis5150) #7

@sanjayws does this look correct?


(John Cr) #8

Hi quintis,
Same issue hare, did you how do you fix it?, Have 4 days and still have the issue