Asterisk won't start after upgrade to 13

Let’s try this again

fwconsole ma download
fwconsole ma install framework


use asterisk;
select * from admin where variable = 'version';

Not sure if it made a difference since I did it as root both times, but I changed out of one of the /etc directories I was working in to /root.

mysql> select * from admin where variable = ‘version’;
| variable | value |
| version | |

Checking for updates on the module admin shows what is to be expected and “Apply Config” works! Is there anything else I need to do/check?

No I actually had to fix the framework package to allow you to continue

You should be good to go

1 Like

I restored a backup from another server (which I’d done manually before) and now I’m getting the retrieve_conf error again.

exit: 1
Whoops\Exception\ErrorException: mkdir(): No such file or directory in file /var/www/html/admin/libraries/BMO/Media.class.php on line 34
Stack trace:

  1. Whoops\Exception\ErrorException->() /var/www/html/admin/libraries/BMO/Media.class.php:34
  2. Whoops\Run->handleError() :0
  3. mkdir() /var/www/html/admin/libraries/BMO/Media.class.php:34
  4. FreePBX\Media->__construct() /var/www/html/admin/libraries/BMO/Self_Helper.class.php:125
  5. FreePBX\Self_Helper->autoLoad() /var/www/html/admin/libraries/BMO/Self_Helper.class.php:37
  6. FreePBX\Self_Helper->__get() /var/lib/asterisk/bin/retrieve_conf:40

Odd. I ran the commands mentioned earlier and fixed it (after noticing the same behavior on the module admin page).

I figured I’d start a new topic, but in case the two are related I’m getting “SQLSTATE[42S22]: Column not found: 1054 Unknown column ‘reversal’ in ‘field list’” when adding an inbound route.

I have exactly the same issue as bwaynef running on a Raspbx system…

namely, the fwconsole service won’t start on a reboot. If I type:

fwconsole start

from the CLI, then it sets all the permissions and starts normally.

When I run:

amportal start

I get…

[email protected]:/usr/local/sbin# amportal start

Please wait…
PHP Parse error: syntax error, unexpected ‘foreach’ (T_FOREACH) in Command line code on line 6

PHP Notice: Undefined variable: amp_conf in /var/lib/asterisk/bin/gen_amp_conf.php on line 18
PHP Warning: Invalid argument supplied for foreach() in /var/lib/asterisk/bin/gen_amp_conf.php on line 18
astrundir in ‘/etc/asterisk’ is set to but the directory
does not exist. Attempting to create it with:
'mkdir -p ’

mkdir: missing operand
Try `mkdir --help’ for more information.
Attempt to execute 'mkdir -p ’ failed with an exit code of 1
You must create this directory and the try again.
[email protected]:/usr/local/sbin#

I think this happens because v13 installs fwconsole with default ownership and 744 permission(?) in /var/lib/asterisk/bin.

If your install does not set /var/lib/asterisk as the asterisk home directory then the default ownership of the folder is “root” instead of “asterisk” . So now asterisk has no ability to run fwconsole which is what is needed to do “fwconsole chown” and fix the permission.

“chown asterisk. /var/lib/asterisk/bin/fwconsole” followed by “fwconsole chown” should fix everything.