Asterisk VoIP Weird Problem

Hi, I’m using Asterisk to make multiple outgoing calls to clients, but I believe one of the companies I’m trying to reach have blocked VoIP calls and allowed calls via ISDN and ordinary mobile phones only. whenever I try and make a call via my softphone I get a busy response in the CLI the call does not even start, just cuts in an instant, but when I call the same number using gsm phone the call goes fine! how weird is that? I’m so overwhelmed to know what they have done.

---------------- what I already tried but no success -----------------
of course, I tried to contact them but the ordinary staff doesn’t know a bit about their system.
I have used 4 different sip providers. and results were the same
multiple mobile caller id, I even used the same one as on my gsm mobile.
tried 2 asterisk servers
----------------- what I think -----------------
I think they have blocked VoIP inbound calls somehow. and allowed only gsm calls!
they may be blocked some sort of VoIP codecs but I suspect that is the case

---------------- what is weird ----------------
what is weird here is the instant cut, I mean the second you click the call button it cuts and gets a busy message on my CLI.
I changed the caller ID in my asterisk from mobile to a landline ID and guess what…I did not get the instant cut nor the busy message, the call works but forwards me to a mailbox message from that company!!

my mind nearly going to blast wanting to know what they have done, I’m kinda amazed

Try another VSP, there is no way for the callee to know how the call was originated but some VSP;s are not as competent as others when routing calls

1 Like

I’m using 4 different SIP providers, and they are working very well. and I have only this one case number with a busy response.

It’s possible (or not impossible) that all of them are using the same underlying carrier for termination.

1 Like

OK, so now this is like the third forum this has been cross posted to and in the other two forums the answers about setup where given. The debugs show a 486 Busy Here on all the test calls that were shown.

The OP has been told to fix their SIP trunks which are configured wrong and they were told to contact their provider to get more details about this. None of that has been done but new posts keep being made for the same problem.

@medpks007 Have you done any thing that was told to you in the other forums?

2 Likes

“whenever I try and make a call via my softphone I get a busy response in the CLI the call does not even start, just cuts in an instant,”

Command line interface (CLI) is for displaying messages as; info, warning, etc.

“what is weird here is the instant cut, I mean the second you click the call button it cuts and gets a busy message on my CLI.”

What it mean exactly with “busy message on my CLI”??

1 Like

On a successful call (from your mobile), is this number answered by an IVR or announcement so it can be called without disturbing a human? If so, please post the number (or send it to me by PM). I’ll test using various carriers and report results.

Or, at the Asterisk command prompt, type
pjsip set logger on
or
sip set debug on
according to trunk type.
Then, make a failing call, paste the Asterisk log at pastebin.freepbx.org and post the link here.

Also, I tried to find your posts at voip-info.org. Google shows them but the links are bad. Did you delete them?

1 Like

I have done everything that could pop into your mind including contacting my sip provider as I mentioned in the post above.

My system works fine with no bugs at all, all the sip trunks are configured right and working as expected. as I’m using it to make daily calls to the same phone range every day.
I’m sorry if posting in other forums is annoying to you, but I’m only trying to reach someone that could help.

that would be great, i will PM you

yes, I set the sip debug on, to see what actually is happening.

Got SIP response 486 “Busy Here” back from 87.238 xxxxxxx
– SIP/World-0000004f is busy
== Everyone is busy/congested at this time (1:1/0/0)

they actually banned me for creating tow posts.

please excuse me im new here, i tried to PM you but i didnt find any direct way on your profile.

If you click the S in the purple 🟣 on the left of this post, you should see a message box. I’ll also send a PM you can answer.

1 Like

If Got SIP response 486 “Busy Here” back from 87.238 xxxxxxx , is a clearly SIP provider remote issue, nothing to do on local site (no one of local technologies could solved remote issues).

1 Like

What did they say about the 486 Busy?

1 Like

they said they are trying to call the number but it is busy for them too. the sip 486 means busy, that’s what they said. they are not experts in asterisk nor VoIP systems. just some staff that try to resolve ordinary problems for clients.

honestly i dont know anymore, i thought that too at first, then i tried using many other Sip Providers and always getting the busy message. the call is only reachable when calling using GSM phone. sounds like they have spoke to the T1 provider to filter thier incoming calls to GSM only!

Does the company want your calls?

Have you contacted them using a GSM phone to ask them why you can’t call them over VoIP?

Trying to figure this out from your side will likely fail.

1 Like

If any of your SIP providers allow customizing the outbound caller ID, have you tried setting that to your mobile number?

I don’t see a message from you. Have you solved this (please post solution), or given up?

I am just not buying that four different providers all have the same exact issue and response for support.

I think we need to see calls from all 4 providers to see if there is a real difference.