Asterisk-Voicemail-FreePBX -Realtime

Hello,

( i posted this on the Asterisk forum but was pinpointed to this forum - please dont pinpoint me back :wink: )

I am a new user, exploring Asterisk
I have setup Asterisk 11.12 with FreePBX…

Question 1:
What would be the best/proper way to route call directly to voicemail ?

Question 2:

I want to build some kind of voicemail platform and do not want to reload Asterisk time after time.
So
i put the voicemailboxes in realtime (Mysql- database voicemail-table
voicemail) Asterisk connects ok to the voicemail database, and in
voicemail.conf it is set to realtime
[general]
switch =>Realtime

I setup an incoming route with a misc destination pointing to feature
code *98 (voicemail) When i call in i am asked to input my
voicemailbox (1000) but then i get a wrong ping
I see this

– Executing [*[email protected]:15] NoOp(“SIP/9999-00000002”, “app-dialvm: BAD mailbox [email protected]”) in new stack

I think it using the FreePBX setting of the voicemail and not the realtime setting ???

Whats going wrong here ?
Can anybody answer my questions ?

Help is highly appreciated!

FreePBX is not setup to handle realtime

Whenever an issue is discussed with voicemail realtime is never a proper option. Realtime is like communism. It looks fantastic on paper but implementation leaves something to be desired.

If you are looking for something purely as a voicemail server you may consider writing something on top of asterisk 12/13 with their rest api. FreePBX is a full PBX solution. If you need a PBX it is the bees knees. If you only need one feature such as voicemail then you can trim away all the stuff you Dont need and have a more lean platform…

1 Like

Ok,

Point taken…

What is thew best setup in FreePBX to go straight to voicemail ?

That’s an easy one in FreePBX, choose the appropriate voicemail choice of the desired extension in your inbound route.

You might also want to look into FreeSwitch for what you are trying to do, it is both less functional as a PBX but also less constrained by that “overload” . . .