Asterisk version switch to 18 LTS fails

I decided to see how Asterisk 18 would run on a system vs the standard 16 LTS release, but when I try and use asterisk-version-switch to change, it fails on the g729 module saying it’s not available.

asterisk18-g729-2002-5.sng7.x8 FAILED                                  [Errno -1] Package does not match intended download. Suggestion: run yum --enablerepo=sng-pkgs clean metadata
Trying other mirror.
(11/20): asterisk18-flite-2.4-6_2505af1.sng7.x86_64.rpm                                          | 8.2 kB  00:00:00     
(12/20): asterisk18-ogg-18.6.0-1.sng7.x86_64.rpm                                                 | 8.8 kB  00:00:00     
(13/20): asterisk18-odbc-18.6.0-1.sng7.x86_64.rpm                                                |  64 kB  00:00:00     
(14/20): asterisk18-res_digium_phone-3.6.5-1.sng7.x86_64.rpm                                     | 858 kB  00:00:00     
(15/20): asterisk18-resample-18.6.0-1.sng7.x86_64.rpm                                            |  14 kB  00:00:00     
(16/20): asterisk18-voicemail-18.6.0-1.sng7.x86_64.rpm                                           |  82 kB  00:00:00     
(17/20): jansson-devel-2.10-1.el7.x86_64.rpm                                                     | 8.9 kB  00:00:00     
(18/20): jansson-devel-doc-2.10-1.el7.noarch.rpm                                                 | 123 kB  00:00:00     
(19/20): jansson-2.10-1.el7.x86_64.rpm                                                           |  37 kB  00:00:00     
Error: Error downloading packages:
  asterisk18-g729-2002-5.sng7.x86_64: [Errno 256] No more mirrors to try.

I did run the yum command clean the metadata, and then tried again, but no luck, same error, so just stayed with 16 LTS for now.

Anyone running into this one?

I did an update on system a bit ago and it updated that package, implying it was already there. I switched this one to 18 months ago though.

It also looks like asterisk-version-switch itself as updated.

Edit: Looks like I switched in January.

Thanks for the response, I took and waited a while, cleaned the cache/metadata again, and then it worked, so I can only guess they fixed the archive issue. I did see mention of the same problem in another thread, so I wasn’t the only one seeing this happen…

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.