Asterisk under Double NAT


I am having a difficultysetting up the Asterisk NOW server for use over the internet.To be more specific , My server is behind a router (which gives a 192.168.1.x /24 address) in a student campus (which again is served by another router, giving ) My question is how do i set up the server and the client such that i can make calls over the internet ,and not just the internal network (the 192.168.1.x/24).I have tried setting NAT yes (for server using the detect external IP and Public IP option, and for client by enabling it in Zoiper).What changes must be done in the GUI , in order to make VoIP calls from internal network to my phone , which is conected to a 4G network ?

I am not sure if what am i saying was very well structured so i am attaching a picture of my issue .
Thanks in advance

When outside of your local network, your cell phone will fail to register, because the router is not allowing traffic through to your internal PBX.
I am assuming you are registering your Zoiper client to the external address.

As you probably don’t have control over the router and can’t configure port forwarding, you won’t be able to make this work.


I have tried using port forwarding on the 1st Router (giving the 192.168.1.x/24) to get traffic incoming on ports 5060-5061 and 10000-20000 to be routed to my server IP address (,as I saw under certain similar posts.For the second router I indeed do not have any way to access it.
Is that what you were refering to ?

Your second router is the gateway to the Internet, so any registration packets sent from your Zoiper client won’t be forwarded to your internal server. That router will deny them.

You will not be able to get this working without changing the Campus router. Zoiper will try to register at the Ip and will not be able to get through to the next router (which you have fixed to route correctly it seems).

Sorry. You could try and use an old router to bridge to a CellPhone hotspot or a Cellular modem, and MAYBE you could get something going, but you would have to try.

Without control of the entire chain, you’ll never get this to work. Even with control, it’s going to be a real challenge. You have to move the phone server out into the 10.30.x.x network for it to completely fail a whole different way (one-way audio, routing issues, etc.)