Asterisk + SugarCRM: click-to-dial issues

Hi all,

I am a new user of Asterisk + SugarCRM.

After configuring both systems following the directions in several docs, my click-to-dial from SugarCRM only shows a pop-up window telling me that is Dialing…[Extn] but nothing happens!

I followed the instructions from and I think it is OK. I also configured Asterisk following several instrucions + forums.

Let me paste some clues:

Asterisk in FreePBX

I configured some SIP extensions (1001, 1002, 1003, 1004). The context is “from-internal”. We can dial from one extension to other using X-Lite SIP phone (Asterisk works!). We also can dial from one SIP extension to a CISCO Call Manager extension (Dial plan and trunks also works!).

I configured manager.conf with the following:

secret = secretpass
permit= <-- allow ALL for test purposes
;permit= <-- commented
;permit= <-- commented
read = system,call,log,verbose,command,agent,user
write = system,call,log,verbose,command,agent,user

SugarCRM 5.5.1 with Asterisk Voice RD Integration (

Admin --> System Settings (Asterisk)

Enable Asterisk Integration [X]
Enable Asterisk Pro [] (unchecked, I have sugarcrm CE)
Asterisk Server: [IP address]
Asterisk Port: 5038
Asterisk Username: sugaruser
Asterisk Secret: secretpass
Asterisk Internal context: from-internal
Asterisk External Context: from-internal
Asterisk Phone Icon [X]

There is no place to configure a timeout.

Finally, we configured “My Account” to have the Extension “SIP/1004” and created a contact with the phone “1003” (we also tried using “SIP/1003”).

From Asterisk, when increasing the trace level (we used 26 “v”! -verbose-):

cd /etc/asterisk
asterisk -vvvvvvvvvvvvvvvvvvvvvvvvvvr

The only output is:

== Manager ‘sugaruser’ logged on from <-- the IP from the user trying to call
== Manager ‘sugaruser’ logged off from

Asterisk full log file:
[Sep 16 14:46:30] VERBOSE[4539] manager.c: == Manager ‘sugaruser’ logged on from
[Sep 16 14:46:30] VERBOSE[4539] manager.c: == Manager ‘sugaruser’ logged off from

are we missing anything?

Thanks a lot!

  • PS: Sorry for my english!

Hi, siggy

We installed FreePBX running under Linux CentOS. Our SugarCRM is on Win2003 Server in VMware. I do not know how it will work in a Mac but I think the Compaq Proliant is enough.

I’m on holidays until Jan/10: I cannot give you details of our installation but I’m sure we did not have to fight with writing/executing permissions (as usual in Linux) to build our Asterisk/FreePBX. I remember it was an straight ahead installation.

To integrate SugarCRM, just follow and fix it with the comments above.

Our system has the following items: some X-Lite SIP phones that can perform calls between them and one trunk connected to our Cisco CallManager to allow the SIP phones to call the CCM extensions (and viceversa) and “the street”.

Good luck and Merry Christmas from Spain

Thank you so much…I really appreciate it
I’m going to “test box” the current sugar 6.0, with asterisk.
The problem with the Proliant server is, I installed the wrong tar ball and cannot
remove it from the dashboard, to load the older version of SIPSTATION 2.5 tgz…
Newbie becoming a novice in short order;))))

Have a great holiday…talk to you soon.


Thank you for posting everything.
I am using elastix 1.6/sugar 4.5
Were you able to use sugar 5.5 with freepbx or with elastix?
I had this package working with our old provider.
Now with SIPSTATION…thinking of doing a completely new install on
my Mac 27, and abandoning my proliant G3.

Would you have your entire procedure available?

Thank in advance

Hello again,

It is solved. It was necessary to add “originate” permissions to the sugaruser in manager.conf

Thank you