Asterisk SIP Settings

In the asterisk sip settings, At the bottom of the page, there is a button to add new field. This does not work. It does work in the IAX settings.

Is this in one of the FreePBX menus/modules? I can’t find it in the default setup.

Goto the tools section. Down about half way is the Asterisk SIP Settings under the System Administrator. Scroll to the bottom and you will see the Add Field button.

I have FreePBX and don’t have “Asterisk SIP Settings” under System Administration. Maybe that comes from a module I don’t have installed.

It is in 2.6 and above.

what browser did it fail on, specific to the version please, so it can be looked at.

if you could, file a bug indicating the browser it failed on (with revision info) and the browser you switched to that worked.


Sorry, I mistyped that, went from 2.6.0 to Good call. It is browser related, works fine with Chrome. Thanks for the suggestion although I should have thought of it myself.

I haven’t heard of any bug reports on that broken, but in any event, it won’t be looked at for 2.6 as 2.6 is not supported.

If you are upgrading, you would be better served to upgrade to the latest stable, which is 2.8, and where, if you are still running into this issue it will be looked at in a bug report.

You may also want to provide information around what browser you are using, and make sure you try it on different browsers, in case it is browser related, since it really should work. (and if it works with iaxsettings, then it’s probably something else in the javascript that is broken thus indirectly affecting that feature, since otherwise it should be pretty identical to the iaxsettings module.

Has anyone gotten a solution to this? I just completed an upgrade to 2.6 and took all my sip configs out of sip_general_custom.conf in response to the big red error message on the SIP Settings page but… I can’t add them back in because the Add Field button doesn’t function on the SIP Settings page. It works fine on the IAX Settings page but that doesn’t help me enable tcp or tls support.