Asterisk on-demand recording volume too low for remote, but local volume OK


I am trying to use on-demand call recording.
My extension can be heard fine on the recording, and although I can hear the far end clearly when on the phone, I cannot hear the far end on the recording, except for odd ‘breakthrough’ when the far end momentarily peaks in volume for an odd fraction of a second. This appears to happen whether I am silent or speaking.

What can I do to adjust the remote volume for the on-demand recording so I can hear both ends of the conversation and not just one?




The on demand recording mixes both the RX and the TX streams of your bridged connection, it will be the same as what you hear unless your handset has a local AGC (many do). What sort of trunks are you using? If Analog then check your RX/TX gains in your DAHDI setup.

I can confirm that the level is good for live, but you can only hear the local and not the remote on the recording.
I am using default levels on all handsets (Panasonic KX-UTxxx).
This happens for analog (Grandsteam HT-503) and digital PJSIP trunk.
DAHDI is not running (DAHDi Doesn’t appear to be running. Click the ‘Restart/Reload Dahdi Button’ Below) - I am using Asterisk 13 am waiting for the release of the new fax support.
Are there any record level setting /option anywhere? Does anybody know which module/ file is responsible for this so I can debug the source?
BTW - voicemail works fine and the remote volume is good for voicemail.