Asterisk not logging

Hello All,

Running FreePBX 15 ( ) I just migrated a FreePBX 13 over to 15.
Everything is running, however asterisk log is empty, so troubleshooting is a little tough.
I tried reinstalling different modules and OS level logging related rpms, but no matter what FULL doesn’t exist.

Any suggestions appreciated.

1 Like

There is apparently a recent bug affecting logs for some people, but I don’t know the details. If nothing logs when you attempt a call, go to Settings -> Asterisk Logfile Settings -> Log Files and check that for both console and full, Debug, Error, Notice, Verbose and Warning are turned on. If no luck, reboot the server and check again. If still no luck, post details (what did the logfile settings show, does console logging work, etc.)

Thanks for the quick reply!

It looks fine settings wise, but a reboot etc, is not fixing the issue as I did that and other things several times.
My settings look like the below which is the same for my other servers.

Console logging working? If not, does e.g.
core set verbose 3

Would that not be the same as me running rasterisk -rvvvvv ??
Literally nothing in the log file not even on start and stop.

Sorry, I’m stumped. In Settings → Advanced Settings, confirm that Asterisk Log Dir is correctly set.

There have been several threads started in the last 3 days related to logging having stopped.
(sort by latest post).
I suspect that they might have been caused by

but there were also some security updates affecting logs.

With luck, you’ll find a clue there. Otherwise, submit a bug report.

Thanks I did search before posting, but you know how that goes, I search for something one way vs how it was written… didn’t see anything.
Let see if the Sangoma team sees something in the morning.

This was solved for me checking my log settings in the GUI. I was seeing the same thing as VoIPTek. Nothing in “full” log starting two days ago when the security updates were applied. I also had nothing in the console with:

asterisk -rvvvvv (or any other verbosity level)

Apparently the updates set all my Full log and Console log settings to “Off”. After resetting the desired settings to “On” and saving, then both the console and Full log started receiving data.

1 Like

Thanks @bhotrock

For those of you looking for the solution, and you don’t have a reference, the below image shows what the default settings were.

Before you claim a solution

Is Fail2ban’s watched log file being created and populated in the “distro” ?

because without the security setting, fail2ban will be watching a possibly non-existent file without any useful content. This might be a problem :wink:

I don’t understand. The image you posted as the Solution shows the same categories enabled as the one posted earlier in the thread where you said it didn’t help. However, the newer screenshot is obviously from a different version of the module. Can you please explain?

I see that, not sure what happened, another update after that one, because my settings were all off.
I have to go back and read that, but I could have also gone onto the wrong box.
The update definitely turns off the logging there.

Summary of issue and resolution: Bug in Asterisk Logfiles Module ver 15.0.4

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.