Asterisk is not running automatically after rebooting


(Carlos S) #1

Hi mates:

Asterisk is not running automatically after rebooting

By SSH shows this message: “Firewall is currently in delayed startup mode, as this machine was recently rebooted. The firewall service will automatically start after this machine has been running for 5 minutes”

and

“Firewall service will start automatically in 30 seconds or less!”

and

“Firewall service now starting.”

But asterisk never works…

[[email protected] ~]# service asterisk status
● asterisk.service - LSB: Asterisk PBX
Loaded: loaded (/etc/rc.d/init.d/asterisk; bad; vendor preset: disabled)
Active: inactive (dead)
Docs: man:systemd-sysv-generator(8)

To run everything again I have to execute: fwconsole start

How can i do to start everything automatically after a reboot?

I have just update from 13 to 14.

Thanks you very much in advance


(Carlos S) #2

After rebooting, the GUI is showing in red: “Can Not connect asterisk”


(Jared Busch) #3

That does not mean Asterisk is not running. It means the system can’t find it though. I see this often on upgrades.

If your phones are registered, then Asterisk is online.

The firs thing to do is simply restart everything without a reboot.

fwconsole restart

(Carlos S) #4

Thanks you very much @sorvani

The problem now i that i can’t make calls between internal extensions… I can make calls to external phones but not between asterisk extensions :frowning: