Asterisk in SIP header instead of username


(Paul) #1

I have been having some issues with two instances of FreePBX I manage. During the troubleshooting process with my trunk provider they brought up the following

11:32:43 PM [Mauro] No problem. We also suggest you check your trunk configuration as we're 
 receiving "asterisk" as the contact header. We require it to be your SIP username
11:33:22 PM [Mauro] <sip:asterisk@45.XX.XX.11:5060> to <sip:myusername@45.XX.XX.11:5060>

Any thoughts on how I may accomplish the header configuration change? This is happening on both instances, one which is brand new and one which was recently updated.

Thanks


#2

In the trunk, try setting Contact User to myusername
If you still have trouble, report where the incorrect Contact appears (outbound REGISTER, outbound INVITE, response to incoming INVITE).


(David55) #3

Or find a service provider who understands SIP; the only purpose of Contact is to provide an address that gets back to the right part of the sender, and, for that, the provider only needs the domain part. If they are using it to identify the account, they are reading more into it than they legitimately can do.

In practice, Asterisk has no use for the user part, so the only valid use would be if you had an incoming load balancing proxy.


(Paul) #4

In case this comes up for someone else ( I misread Stewart1’s response)

Trunks -> select trunk to edit -> pjsip setting -> advanced -> Contact User


(Tom Ray) #5

You can also go into Advanced Settings for PJSIP and turn on “Use CallerID as Contact” which will stop setting it as asterisk.