Asterisk has problem with network?

if i run asterisk in network, there is not any problem with incoming calls from trunk.
But if i run asterisk in network so there is a problem with incoming calls. Asterisk sends TRYING sip message to outside sip client than immediatelly sends 404 NOT FOUND message.
Outgoing calls work well in each of network situations.

Is it a bug of asterisk or am i doing anything wrong?

There is no bug in Asterisk. In fact I’ve used an Asterisk server in a network quite happily. You have a configuration issue. Make sure that the network is included in your local networks in Asterisk SIP Settings.

it was adjusted like this.

Definitely no issues with 10-dot networks here.

Do you also have the right settings in Admin > System Admin > Network Settings ?

There is not any option like “System Admin” or “Network Settings” under Admin section.

Then I think you need to install the System Admin module - there’s a free version and a Pro (paid) version. Both have the Network Settings facility.

There is not any free version of “System Admin” .My Freepbx running over Ubuntu 12.04
Are you sure that there is no way to run Asterisk on network? My only soulution is “System Admin” module??

Yes there is a free version (also called “standard”).

BTW - the Pro version is probably the best $25 you could spend today :slight_smile:

OP is running a self install on Ubuntu and if you are not running the FreePBX Distro, you can’t run commercial modules.

Good news - there are two version of System Admin for FreePBX Distro systems.

Bad news - I don’t think “passweby’s” system is a straight distro system (since it’s running on Ubuntu.

Having said that - I’ve never encountered a problem with Asterisk running on the 10.x.x.x network that wasn’t caused by a bad network configuration. It’s possible that a netmask somewhere (or some other arcane setting) is getting in the way of this working for you.

So what is the problem in my system?

Yes and no, it’s likely just a configuration issue. My guess is that you don’t have a route to the Internet since you said that it is the outside clients that aren’t working?
Is your internet router in the same network? Google around on how to configure it on Ubuntu but make sure you have your gateway set to the IP of your internet router and that you have working DNS servers configured. If you ping what happens?

Oh wait I didn’t read your original post correctly the first time. As someone pointed out, check your local networks field in the sip settings page, also make sure your external IP is set correctly on those pages and make sure any port forwarding that you have set up for the 192. network you setup for the 10. Network.